gpg-tui-0.11.0.ebuild 6.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310
  1. # Copyright 2017-2024 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. CRATES="
  5. addr2line@0.21.0
  6. adler@1.0.2
  7. ahash@0.8.8
  8. aho-corasick@1.1.2
  9. allocator-api2@0.2.16
  10. android-tzdata@0.1.1
  11. android_system_properties@0.1.5
  12. anstream@0.6.13
  13. anstyle@1.0.6
  14. anstyle-parse@0.2.1
  15. anstyle-query@1.0.0
  16. anstyle-wincon@3.0.2
  17. anyhow@1.0.81
  18. async-trait@0.1.77
  19. autocfg@1.1.0
  20. backtrace@0.3.69
  21. better-panic@0.3.0
  22. bitflags@1.3.2
  23. bitflags@2.4.0
  24. block@0.1.6
  25. block-buffer@0.10.4
  26. build-rs@0.1.2
  27. bumpalo@3.13.0
  28. bytemuck@1.15.0
  29. byteorder@1.5.0
  30. bytes@1.5.0
  31. cassowary@0.3.0
  32. castaway@0.2.2
  33. cc@1.0.83
  34. cfg-expr@0.15.5
  35. cfg-if@1.0.0
  36. chrono@0.4.35
  37. clap@4.5.2
  38. clap_builder@4.5.2
  39. clap_complete@4.5.1
  40. clap_derive@4.5.0
  41. clap_lex@0.7.0
  42. clipboard-win@3.1.1
  43. colorchoice@1.0.0
  44. colorsys@0.6.7
  45. compact_str@0.7.1
  46. console@0.15.7
  47. conv@0.3.3
  48. copypasta@0.8.2
  49. copypasta-ext@0.4.4
  50. core-foundation-sys@0.8.4
  51. cpufeatures@0.2.12
  52. crc32fast@1.4.0
  53. crossterm@0.27.0
  54. crossterm_winapi@0.9.1
  55. crypto-common@0.1.6
  56. cstr-argument@0.1.2
  57. custom_derive@0.1.7
  58. diff@0.1.13
  59. digest@0.10.7
  60. dirs@5.0.1
  61. dirs-next@2.0.0
  62. dirs-sys@0.4.1
  63. dirs-sys-next@0.1.2
  64. dlib@0.5.2
  65. downcast-rs@1.2.0
  66. either@1.9.0
  67. encode_unicode@0.3.6
  68. env_filter@0.1.0
  69. env_logger@0.11.3
  70. equivalent@1.0.1
  71. errno@0.3.3
  72. errno-dragonfly@0.1.2
  73. fdeflate@0.3.4
  74. flate2@1.0.28
  75. fxhash@0.2.1
  76. generic-array@0.14.7
  77. gethostname@0.2.3
  78. getrandom@0.2.10
  79. gimli@0.28.0
  80. gpg-error@0.6.0
  81. gpgme@0.11.0
  82. gpgme-sys@0.11.0
  83. hashbrown@0.14.0
  84. heck@0.4.1
  85. hex@0.4.3
  86. home@0.5.5
  87. humantime@2.1.0
  88. iana-time-zone@0.1.57
  89. iana-time-zone-haiku@0.1.2
  90. image@0.25.0
  91. indexmap@2.0.0
  92. indoc@2.0.3
  93. itertools@0.12.1
  94. itoa@1.0.9
  95. js-sys@0.3.64
  96. lazy-bytes-cast@5.0.1
  97. lazy_static@1.4.0
  98. libc@0.2.153
  99. libgpg-error-sys@0.6.0
  100. libloading@0.8.0
  101. linux-raw-sys@0.4.7
  102. lock_api@0.4.10
  103. log@0.4.21
  104. lru@0.12.2
  105. malloc_buf@0.0.6
  106. memchr@2.6.3
  107. memmap2@0.5.10
  108. memoffset@0.6.5
  109. memoffset@0.7.1
  110. minimal-lexical@0.2.1
  111. miniz_oxide@0.7.1
  112. mio@0.8.8
  113. nix@0.24.3
  114. nom@7.1.3
  115. num-traits@0.2.16
  116. objc@0.2.7
  117. objc-foundation@0.1.1
  118. objc_id@0.1.1
  119. object@0.32.1
  120. once_cell@1.18.0
  121. option-ext@0.2.0
  122. parking_lot@0.12.1
  123. parking_lot_core@0.9.8
  124. paste@1.0.14
  125. pkg-config@0.3.27
  126. png@0.17.13
  127. pretty_assertions@1.4.0
  128. proc-macro2@1.0.74
  129. quote@1.0.35
  130. ratatui@0.26.1
  131. ratatui-splash-screen@0.1.0
  132. redox_syscall@0.2.16
  133. redox_syscall@0.3.5
  134. redox_users@0.4.3
  135. regex@1.10.3
  136. regex-automata@0.4.6
  137. regex-syntax@0.8.2
  138. rustc-demangle@0.1.23
  139. rustix@0.38.12
  140. rustversion@1.0.14
  141. ryu@1.0.15
  142. scoped-tls@1.0.1
  143. scopeguard@1.2.0
  144. serde@1.0.197
  145. serde_derive@1.0.197
  146. serde_json@1.0.106
  147. serde_spanned@0.6.4
  148. sha2@0.10.8
  149. sha256@1.5.0
  150. shellexpand@3.1.0
  151. signal-hook@0.3.17
  152. signal-hook-mio@0.2.3
  153. signal-hook-registry@1.4.1
  154. simd-adler32@0.3.7
  155. smallvec@1.11.0
  156. smithay-client-toolkit@0.16.0
  157. smithay-clipboard@0.6.6
  158. stability@0.1.1
  159. static_assertions@1.1.0
  160. strsim@0.11.0
  161. strum@0.26.1
  162. strum_macros@0.26.1
  163. syn@1.0.109
  164. syn@2.0.46
  165. system-deps@6.1.1
  166. target-lexicon@0.12.11
  167. terminal_size@0.3.0
  168. thiserror@1.0.48
  169. thiserror-impl@1.0.48
  170. tinytemplate@1.2.1
  171. toml@0.7.8
  172. toml@0.8.8
  173. toml_datetime@0.6.5
  174. toml_edit@0.19.15
  175. toml_edit@0.21.0
  176. tui-logger@0.11.0
  177. typenum@1.17.0
  178. unicode-ident@1.0.11
  179. unicode-segmentation@1.10.1
  180. unicode-width@0.1.11
  181. utf8parse@0.2.1
  182. version-compare@0.1.1
  183. version_check@0.9.4
  184. wasi@0.11.0+wasi-snapshot-preview1
  185. wasm-bindgen@0.2.87
  186. wasm-bindgen-backend@0.2.87
  187. wasm-bindgen-macro@0.2.87
  188. wasm-bindgen-macro-support@0.2.87
  189. wasm-bindgen-shared@0.2.87
  190. wayland-client@0.29.5
  191. wayland-commons@0.29.5
  192. wayland-cursor@0.29.5
  193. wayland-protocols@0.29.5
  194. wayland-scanner@0.29.5
  195. wayland-sys@0.29.5
  196. which@4.4.2
  197. winapi@0.3.9
  198. winapi-i686-pc-windows-gnu@0.4.0
  199. winapi-wsapoll@0.1.1
  200. winapi-x86_64-pc-windows-gnu@0.4.0
  201. windows@0.48.0
  202. windows-sys@0.45.0
  203. windows-sys@0.48.0
  204. windows-sys@0.52.0
  205. windows-targets@0.42.2
  206. windows-targets@0.48.5
  207. windows-targets@0.52.0
  208. windows_aarch64_gnullvm@0.42.2
  209. windows_aarch64_gnullvm@0.48.5
  210. windows_aarch64_gnullvm@0.52.0
  211. windows_aarch64_msvc@0.42.2
  212. windows_aarch64_msvc@0.48.5
  213. windows_aarch64_msvc@0.52.0
  214. windows_i686_gnu@0.42.2
  215. windows_i686_gnu@0.48.5
  216. windows_i686_gnu@0.52.0
  217. windows_i686_msvc@0.42.2
  218. windows_i686_msvc@0.48.5
  219. windows_i686_msvc@0.52.0
  220. windows_x86_64_gnu@0.42.2
  221. windows_x86_64_gnu@0.48.5
  222. windows_x86_64_gnu@0.52.0
  223. windows_x86_64_gnullvm@0.42.2
  224. windows_x86_64_gnullvm@0.48.5
  225. windows_x86_64_gnullvm@0.52.0
  226. windows_x86_64_msvc@0.42.2
  227. windows_x86_64_msvc@0.48.5
  228. windows_x86_64_msvc@0.52.0
  229. winnow@0.5.15
  230. winreg@0.10.1
  231. x11-clipboard@0.7.1
  232. x11rb@0.10.1
  233. x11rb-protocol@0.10.0
  234. xcursor@0.3.4
  235. xml-rs@0.8.18
  236. yansi@0.5.1
  237. zerocopy@0.7.32
  238. zerocopy-derive@0.7.32
  239. zune-core@0.4.12
  240. zune-jpeg@0.4.11
  241. ${PN}@${PV}
  242. "
  243. inherit bash-completion-r1 cargo
  244. DESCRIPTION="Terminal User Interface for GnuPG"
  245. HOMEPAGE="
  246. https://crates.io/crates/gpg-tui
  247. https://github.com/orhun/gpg-tui
  248. "
  249. SRC_URI="
  250. ${CARGO_CRATE_URIS}
  251. https://github.com/orhun/${PN}/raw/v${PV}/man/${PN}.1 -> ${P}.man.1
  252. https://github.com/orhun/${PN}/raw/v${PV}/man/${PN}.toml.5 -> ${P}.toml.man.5
  253. "
  254. LICENSE="MIT"
  255. # Dependent crate licenses
  256. LICENSE+="
  257. Apache-2.0 Apache-2.0-with-LLVM-exceptions Boost-1.0 ISC LGPL-2.1
  258. MIT MPL-2.0 Unicode-DFS-2016 Unlicense
  259. "
  260. SLOT="0"
  261. KEYWORDS="amd64 ~x86"
  262. RESTRICT="mirror"
  263. DEPEND="
  264. app-crypt/gpgme
  265. dev-libs/libgpg-error
  266. x11-libs/libxcb
  267. "
  268. RDEPEND="${DEPEND}"
  269. BDEPEND="x11-libs/libxkbcommon"
  270. src_unpack() {
  271. cargo_src_unpack
  272. local man="${T}/man"
  273. mkdir -- "${man}" || die
  274. cp -v -- "${DISTDIR}/${P}.man.1" "${man}/${PN}.1" || die
  275. cp -v -- "${DISTDIR}/${P}.toml.man.5" "${man}/${PN}.toml.5" || die
  276. }
  277. src_install() {
  278. cargo_src_install
  279. doman "${T}/man"/*
  280. local exe="${ED}/usr/bin/${PN}-completions"
  281. local completions="${S}/completions"
  282. mkdir -p "${completions}" || die
  283. ebegin "generating completions"
  284. OUT_DIR="${completions}" "${exe}"
  285. eend "${?}" 'failed to generate completions' || die "${_}"
  286. rm "${exe}" || die
  287. # bash-completion
  288. newbashcomp "completions/${PN}.bash" "${PN}"
  289. # zsh-completion
  290. insinto /usr/share/zsh/site-functions
  291. doins "completions/_${PN}"
  292. # fish-completion
  293. insinto /usr/share/fish/vendor_completions.d
  294. doins "completions/${PN}.fish"
  295. }