libexecinfo-1.1-r1.ebuild 887 B

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. # Copyright 2021-2024 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit flag-o-matic toolchain-funcs
  5. DESCRIPTION="BSD licensed clone of the GNU libc backtrace facility"
  6. HOMEPAGE="https://www.freshports.org/devel/libexecinfo"
  7. SRC_URI="http://distcache.freebsd.org/local-distfiles/itetcu/${P}.tar.bz2"
  8. LICENSE="BSD-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ~x86"
  11. IUSE="elibc_musl static"
  12. src_prepare() {
  13. # patches from voidlinux
  14. eapply -p0 "${FILESDIR}"/*.patch
  15. eapply_user
  16. sed -i "${PN}.pc" -e "/Version:/s@version@${PV}@" || die
  17. }
  18. src_compile() {
  19. append-flags '-fno-omit-frame-pointer'
  20. emake CC="$(tc-getCC)" AR="$(tc-getAR)" dynamic $(usev static)
  21. }
  22. src_install() {
  23. insinto "/usr/$(get_libdir)/pkgconfig"
  24. doins "${PN}.pc"
  25. doheader *.h
  26. dolib.so "${PN}.so.1"
  27. dosym "${_}" "/usr/$(get_libdir)/${PN}.so"
  28. use static && dolib.a *.a
  29. }