xinput-gui-9999.ebuild 661 B

123456789101112131415161718192021222324252627282930
  1. # Copyright 2020-2023 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. DISTUTILS_USE_PEP517=setuptools
  5. PYTHON_COMPAT=( python3_{10..12} )
  6. inherit distutils-r1
  7. DESCRIPTION="A simple GUI for Xorg's Xinput tool"
  8. HOMEPAGE="https://github.com/IvanFon/xinput-gui"
  9. if [[ ${PV} == "9999" ]]; then
  10. EGIT_REPO_URI="https://github.com/IvanFon/${PN}.git"
  11. inherit git-r3
  12. else
  13. SRC_URI="https://github.com/IvanFon/${PN}/releases/download/${PV}/${P}.tar.gz"
  14. KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~mips ppc ppc64 sparc x86"
  15. fi
  16. LICENSE="GPL-3"
  17. SLOT="0"
  18. RDEPEND="
  19. dev-python/pygobject
  20. x11-apps/xinput
  21. x11-libs/gtk+:3
  22. "