clayout-9999.ebuild 696 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 2022-2023 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. DESCRIPTION="Save own keyboard layout for each window"
  5. HOMEPAGE="https://notabug.org/dm9pZCAq/clayout"
  6. if [ "${PV}" = 9999 ]; then
  7. inherit git-r3
  8. EGIT_REPO_URI="https://notabug.org/dm9pZCAq/${PN}.git"
  9. else
  10. SRC_URI="
  11. https://notabug.org/dm9pZCAq/${PN}/archive/${PV}.tar.gz
  12. -> ${P}.tar.gz
  13. "
  14. KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
  15. S="${WORKDIR}/${PN}"
  16. fi
  17. LICENSE="GPL-3"
  18. SLOT="0"
  19. DEPEND="x11-libs/libxcb[xkb]"
  20. RDEPEND="${DEPEND}"
  21. src_install() {
  22. dobin "${PN}"
  23. }