mdevd-0.1.6.3.ebuild 633 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 2021-2023 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. DESCRIPTION="A kernel event manager compatible with mdev.conf"
  5. HOMEPAGE="
  6. https://skarnet.org/software/mdevd/
  7. https://github.com/skarnet/mdevd
  8. "
  9. SRC_URI="
  10. https://github.com/skarnet/${PN}/archive/v${PV}.tar.gz
  11. -> ${PF}.tar.gz
  12. "
  13. KEYWORDS="~amd64 ~arm ~x86"
  14. DEPEND=">=dev-libs/skalibs-2.14.0.0"
  15. LICENSE="ISC"
  16. SLOT="0"
  17. RDEPEND="${DEPEND}"
  18. src_configure() {
  19. econf --with-sysdeps="${EPREFIX}/usr/$(get_libdir)/skalibs"
  20. }
  21. src_install() {
  22. dobin "${PN}"{,-coldplug}
  23. insinto /etc
  24. doins "${FILESDIR}/${PN}.conf"
  25. }