smu-1.5.ebuild 646 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 2021 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. DESCRIPTION="Simple markup - markdown like syntax"
  5. HOMEPAGE="https://github.com/Gottox/smu"
  6. SRC_URI="
  7. https://github.com/Gottox/${PN}/archive/refs/tags/v${PV}.tar.gz
  8. -> ${P}.tar.gz
  9. "
  10. LICENSE="MIT"
  11. SLOT="0"
  12. KEYWORDS="amd64 ~x86"
  13. DOCS=( documentation )
  14. src_prepare() {
  15. sed -i ./config.mk \
  16. -e '/^CFLAGS/{s/=/+&/;s/-\(g\|O.\)\s\+//g}' \
  17. -e '/^LDFLAGS/s/=/+&/' \
  18. -e '/^CC/d' \
  19. || die
  20. sed -i ./Makefile -e '/^all:/s/\s\+options//' || die
  21. default
  22. }
  23. src_install() {
  24. emake PREFIX=/usr DESTDIR="${ED}" install
  25. einstalldocs
  26. }