zsh-you-should-use-1.7.3.ebuild 780 B

1234567891011121314151617181920212223242526272829
  1. # Copyright 2021-2023 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. DESCRIPTION="ZSH plugin that reminds you to use existing aliases for commands you just typed"
  5. HOMEPAGE="https://github.com/MichaelAquilina/zsh-you-should-use"
  6. SRC_URI="
  7. https://github.com/MichaelAquilina/${PN}/archive/refs/tags/${PV}.tar.gz
  8. -> ${P}.tar.gz
  9. "
  10. LICENSE="GPL-3"
  11. SLOT="0"
  12. KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
  13. DEPEND="app-shells/zsh"
  14. RDEPEND="${DEPEND}"
  15. src_install() {
  16. local MY_PN="${PN##zsh-}"
  17. local DOCS=( README.rst )
  18. insinto "/usr/share/zsh/site-contrib/${MY_PN}"
  19. doins "${MY_PN}.plugin.zsh"
  20. einstalldocs
  21. }