draw-0.1.1.ebuild 605 B

1234567891011121314151617181920212223242526272829
  1. # Copyright 2022-2023 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. inherit go-module
  5. DESCRIPTION="Draw in your terminal"
  6. HOMEPAGE="https://github.com/maaslalani/draw"
  7. SRC_URI="
  8. https://github.com/maaslalani/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
  9. https://github.com/dm9pZCAq/gentoo-go-deps/releases/download/${P}/${P}-deps.tar.xz
  10. https://github.com/dm9pZCAq/gentoo-go-deps/releases/download/${P}/${P}-vendor.tar.xz
  11. "
  12. LICENSE="Apache-2.0 BSD MIT"
  13. SLOT="0"
  14. KEYWORDS="amd64"
  15. src_compile() {
  16. ego build
  17. }
  18. src_install() {
  19. dobin "${PN}"
  20. einstalldocs
  21. }