zola-0.18.0.ebuild 9.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499
  1. # Copyright 2023 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. # internal crates are located in `components/`
  5. CRATES="
  6. addr2line@0.21.0
  7. adler@1.0.2
  8. ahash@0.7.7
  9. ahash@0.8.6
  10. aho-corasick@0.7.20
  11. aho-corasick@1.1.2
  12. ammonia@3.3.0
  13. android-tzdata@0.1.1
  14. android_system_properties@0.1.5
  15. anstream@0.6.5
  16. anstyle@1.0.4
  17. anstyle-parse@0.2.3
  18. anstyle-query@1.0.2
  19. anstyle-wincon@3.0.2
  20. any_ascii@0.1.7
  21. anyhow@1.0.75
  22. arrayvec@0.7.4
  23. assert-json-diff@2.0.2
  24. atty@0.2.14
  25. autocfg@1.1.0
  26. backtrace@0.3.69
  27. base64@0.21.5
  28. bincode@1.3.3
  29. bit_field@0.10.2
  30. bitflags@1.3.2
  31. bitflags@2.4.1
  32. block-buffer@0.7.3
  33. block-buffer@0.10.4
  34. block-padding@0.1.5
  35. bstr@1.8.0
  36. build_const@0.2.2
  37. bumpalo@3.14.0
  38. byte-tools@0.3.1
  39. bytecount@0.6.7
  40. bytemuck@1.14.0
  41. byteorder@1.5.0
  42. bytes@0.4.12
  43. bytes@1.5.0
  44. camino@1.1.6
  45. cargo-platform@0.1.5
  46. cargo_metadata@0.14.2
  47. cc@1.0.83
  48. cedarwood@0.4.6
  49. cfg-if@0.1.10
  50. cfg-if@1.0.0
  51. chrono@0.4.31
  52. chrono-tz@0.8.4
  53. chrono-tz-build@0.2.1
  54. clap@3.2.25
  55. clap@4.4.11
  56. clap_builder@4.4.11
  57. clap_complete@4.4.4
  58. clap_derive@3.2.25
  59. clap_derive@4.4.7
  60. clap_lex@0.2.4
  61. clap_lex@0.6.0
  62. codemap@0.1.3
  63. color_quant@1.1.0
  64. colorchoice@1.0.0
  65. colored@2.1.0
  66. config@0.1.0
  67. console@0.15.7
  68. convert_case@0.4.0
  69. core-foundation@0.9.4
  70. core-foundation-sys@0.8.6
  71. cpufeatures@0.2.11
  72. crc@1.8.1
  73. crc32fast@1.3.2
  74. crossbeam-deque@0.8.4
  75. crossbeam-epoch@0.9.16
  76. crossbeam-utils@0.8.17
  77. crunchy@0.2.2
  78. crypto-common@0.1.6
  79. css-minify@0.3.1
  80. csv@1.3.0
  81. csv-core@0.1.11
  82. ctrlc@3.4.1
  83. deranged@0.3.10
  84. derive_more@0.99.17
  85. deunicode@1.4.2
  86. digest@0.8.1
  87. digest@0.10.7
  88. displaydoc@0.2.4
  89. doc-comment@0.3.3
  90. either@1.9.0
  91. elasticlunr-rs@3.0.2
  92. encode_unicode@0.3.6
  93. encoding@0.2.33
  94. encoding-index-japanese@1.20141219.5
  95. encoding-index-korean@1.20141219.5
  96. encoding-index-simpchinese@1.20141219.5
  97. encoding-index-singlebyte@1.20141219.5
  98. encoding-index-tradchinese@1.20141219.5
  99. encoding_index_tests@0.1.4
  100. encoding_rs@0.8.33
  101. env_logger@0.9.3
  102. equivalent@1.0.1
  103. errno@0.3.8
  104. error-chain@0.12.4
  105. exr@1.71.0
  106. fake-simd@0.1.2
  107. fastrand@2.0.1
  108. fdeflate@0.3.1
  109. filetime@0.2.23
  110. flate2@1.0.28
  111. flume@0.11.0
  112. fnv@1.0.7
  113. foreign-types@0.3.2
  114. foreign-types-shared@0.1.1
  115. form_urlencoded@1.2.1
  116. fsevent@0.4.0
  117. fsevent-sys@2.0.1
  118. fuchsia-zircon@0.3.3
  119. fuchsia-zircon-sys@0.3.3
  120. futf@0.1.5
  121. futures-channel@0.3.29
  122. futures-core@0.3.29
  123. futures-io@0.3.29
  124. futures-sink@0.3.29
  125. futures-task@0.3.29
  126. futures-util@0.3.29
  127. fxhash@0.2.1
  128. generic-array@0.12.4
  129. generic-array@0.14.7
  130. getrandom@0.1.16
  131. getrandom@0.2.11
  132. gh-emoji@1.0.8
  133. gif@0.12.0
  134. gimli@0.28.1
  135. glob@0.3.1
  136. globset@0.4.14
  137. globwalk@0.8.1
  138. grass@0.13.1
  139. grass_compiler@0.13.0
  140. h2@0.3.22
  141. half@2.2.1
  142. hashbrown@0.11.2
  143. hashbrown@0.12.3
  144. hashbrown@0.14.3
  145. heck@0.4.1
  146. hermit-abi@0.1.19
  147. hermit-abi@0.3.3
  148. html5ever@0.26.0
  149. http@0.2.11
  150. http-body@0.4.6
  151. httparse@1.8.0
  152. httpdate@1.0.3
  153. humansize@2.1.3
  154. humantime@2.1.0
  155. hyper@0.14.27
  156. hyper-rustls@0.24.2
  157. hyper-tls@0.5.0
  158. iana-time-zone@0.1.58
  159. iana-time-zone-haiku@0.1.2
  160. idna@0.5.0
  161. ignore@0.4.21
  162. image@0.24.7
  163. indexmap@1.9.3
  164. indexmap@2.1.0
  165. inotify@0.7.1
  166. inotify-sys@0.1.5
  167. insta@1.34.0
  168. iovec@0.1.4
  169. ipnet@2.9.0
  170. is-docker@0.2.0
  171. is-wsl@0.4.0
  172. itoa@1.0.10
  173. jieba-rs@0.6.8
  174. jobserver@0.1.27
  175. jpeg-decoder@0.3.0
  176. js-sys@0.3.66
  177. kamadak-exif@0.5.5
  178. kernel32-sys@0.2.2
  179. lasso@0.6.0
  180. lazy_static@1.4.0
  181. lazycell@1.3.0
  182. lebe@0.5.2
  183. lexical-sort@0.3.1
  184. libc@0.2.151
  185. libm@0.2.8
  186. libwebp-sys@0.9.4
  187. lindera@0.14.0
  188. lindera-cc-cedict-builder@0.13.5
  189. lindera-core@0.13.5
  190. lindera-decompress@0.13.5
  191. lindera-dictionary@0.13.5
  192. lindera-ipadic@0.13.5
  193. lindera-ipadic-builder@0.13.5
  194. lindera-ko-dic-builder@0.13.5
  195. lindera-unidic-builder@0.13.5
  196. line-wrap@0.1.1
  197. linked-hash-map@0.5.6
  198. linux-raw-sys@0.4.12
  199. lock_api@0.4.11
  200. log@0.4.20
  201. lzma-rs@0.2.0
  202. mac@0.1.1
  203. maplit@1.0.2
  204. markup5ever@0.11.0
  205. memchr@2.6.4
  206. memoffset@0.9.0
  207. mime@0.3.17
  208. mime_guess@2.0.4
  209. minidom@0.12.0
  210. minify-html@0.11.1
  211. minify-js@0.4.3
  212. minimal-lexical@0.2.1
  213. miniz_oxide@0.7.1
  214. mio@0.6.23
  215. mio@0.8.10
  216. mio-extras@2.0.6
  217. miow@0.2.2
  218. mockito@0.31.1
  219. mutate_once@0.1.1
  220. native-tls@0.2.11
  221. net2@0.2.39
  222. new_debug_unreachable@1.0.4
  223. nix@0.27.1
  224. nom@7.1.3
  225. nom-bibtex@0.5.0
  226. nom-tracable@0.9.0
  227. nom-tracable-macros@0.9.0
  228. nom_locate@4.2.0
  229. notify@4.0.17
  230. num-format@0.4.4
  231. num-integer@0.1.45
  232. num-rational@0.4.1
  233. num-traits@0.2.17
  234. num_cpus@1.16.0
  235. num_threads@0.1.6
  236. object@0.32.1
  237. once_cell@1.19.0
  238. onig@6.4.0
  239. onig_sys@69.8.1
  240. opaque-debug@0.2.3
  241. open@5.0.1
  242. openssl@0.10.61
  243. openssl-macros@0.1.1
  244. openssl-probe@0.1.5
  245. openssl-sys@0.9.97
  246. os_str_bytes@6.6.1
  247. parking_lot@0.12.1
  248. parking_lot_core@0.9.9
  249. parse-js@0.10.3
  250. parse-zoneinfo@0.3.0
  251. path-slash@0.2.1
  252. pathdiff@0.2.1
  253. percent-encoding@2.3.1
  254. pest@2.7.5
  255. pest_derive@2.7.5
  256. pest_generator@2.7.5
  257. pest_meta@2.7.5
  258. phf@0.10.1
  259. phf@0.11.2
  260. phf_codegen@0.10.0
  261. phf_codegen@0.11.2
  262. phf_generator@0.10.0
  263. phf_generator@0.11.2
  264. phf_macros@0.10.0
  265. phf_shared@0.10.0
  266. phf_shared@0.11.2
  267. pin-project-lite@0.2.13
  268. pin-utils@0.1.0
  269. pkg-config@0.3.27
  270. plist@1.6.0
  271. png@0.17.10
  272. powerfmt@0.2.0
  273. ppv-lite86@0.2.17
  274. precomputed-hash@0.1.1
  275. proc-macro-error@1.0.4
  276. proc-macro-error-attr@1.0.4
  277. proc-macro-hack@0.5.20+deprecated
  278. proc-macro2@1.0.70
  279. pulldown-cmark@0.9.3
  280. pure-rust-locales@0.7.0
  281. qoi@0.4.1
  282. quick-error@2.0.1
  283. quick-xml@0.17.2
  284. quick-xml@0.31.0
  285. quickxml_to_serde@0.5.0
  286. quote@1.0.33
  287. rand@0.7.3
  288. rand@0.8.5
  289. rand_chacha@0.2.2
  290. rand_chacha@0.3.1
  291. rand_core@0.5.1
  292. rand_core@0.6.4
  293. rand_hc@0.2.0
  294. rayon@1.8.0
  295. rayon-core@1.12.0
  296. redox_syscall@0.4.1
  297. regex@1.10.2
  298. regex-automata@0.4.3
  299. regex-syntax@0.7.5
  300. regex-syntax@0.8.2
  301. relative-path@1.9.0
  302. reqwest@0.11.22
  303. ring@0.17.7
  304. roxmltree@0.18.1
  305. rust-stemmers@1.2.0
  306. rustc-demangle@0.1.23
  307. rustc-hash@1.1.0
  308. rustc_version@0.4.0
  309. rustix@0.38.28
  310. rustls@0.21.10
  311. rustls-pemfile@1.0.4
  312. rustls-webpki@0.101.7
  313. ryu@1.0.16
  314. safemem@0.3.3
  315. same-file@1.0.6
  316. schannel@0.1.22
  317. scopeguard@1.2.0
  318. sct@0.7.1
  319. security-framework@2.9.2
  320. security-framework-sys@2.9.1
  321. semver@1.0.20
  322. serde@1.0.193
  323. serde_derive@1.0.193
  324. serde_json@1.0.108
  325. serde_spanned@0.6.4
  326. serde_urlencoded@0.7.1
  327. serde_yaml@0.9.27
  328. sha-1@0.8.2
  329. sha2@0.10.8
  330. simd-adler32@0.3.7
  331. similar@2.3.0
  332. siphasher@0.3.11
  333. skeptic@0.13.7
  334. slab@0.4.9
  335. slug@0.1.5
  336. smallvec@1.11.2
  337. socket2@0.4.10
  338. socket2@0.5.5
  339. spin@0.9.8
  340. string_cache@0.8.7
  341. string_cache_codegen@0.5.2
  342. strsim@0.10.0
  343. svg_metadata@0.5.0
  344. syn@1.0.109
  345. syn@2.0.41
  346. syntect@5.1.0
  347. system-configuration@0.5.1
  348. system-configuration-sys@0.5.0
  349. tar@0.4.40
  350. tempfile@3.8.1
  351. tendril@0.4.3
  352. tera@1.19.1
  353. termcolor@1.4.0
  354. test-case@3.3.1
  355. test-case-core@3.3.1
  356. test-case-macros@3.3.1
  357. textwrap@0.16.0
  358. thiserror@1.0.51
  359. thiserror-impl@1.0.51
  360. tiff@0.9.0
  361. time@0.3.30
  362. time-core@0.1.2
  363. time-macros@0.2.15
  364. tinystr@0.7.5
  365. tinyvec@1.6.0
  366. tinyvec_macros@0.1.1
  367. tokio@1.35.0
  368. tokio-native-tls@0.3.1
  369. tokio-rustls@0.24.1
  370. tokio-util@0.7.10
  371. toml@0.5.11
  372. toml@0.8.8
  373. toml_datetime@0.6.5
  374. toml_edit@0.21.0
  375. tower-service@0.3.2
  376. tracing@0.1.40
  377. tracing-core@0.1.32
  378. try-lock@0.2.5
  379. typenum@1.17.0
  380. ucd-trie@0.1.6
  381. unic-char-property@0.9.0
  382. unic-char-range@0.9.0
  383. unic-common@0.9.0
  384. unic-langid@0.9.4
  385. unic-langid-impl@0.9.4
  386. unic-segment@0.9.0
  387. unic-ucd-segment@0.9.0
  388. unic-ucd-version@0.9.0
  389. unicase@2.7.0
  390. unicode-bidi@0.3.14
  391. unicode-ident@1.0.12
  392. unicode-normalization@0.1.22
  393. unicode-segmentation@1.10.1
  394. unsafe-libyaml@0.2.10
  395. untrusted@0.9.0
  396. url@2.5.0
  397. utf-8@0.7.6
  398. utf8parse@0.2.1
  399. vcpkg@0.2.15
  400. version_check@0.9.4
  401. walkdir@2.4.0
  402. want@0.3.1
  403. wasi@0.9.0+wasi-snapshot-preview1
  404. wasi@0.11.0+wasi-snapshot-preview1
  405. wasm-bindgen@0.2.89
  406. wasm-bindgen-backend@0.2.89
  407. wasm-bindgen-futures@0.4.39
  408. wasm-bindgen-macro@0.2.89
  409. wasm-bindgen-macro-support@0.2.89
  410. wasm-bindgen-shared@0.2.89
  411. web-sys@0.3.66
  412. webp@0.2.6
  413. webpki-roots@0.25.3
  414. weezl@0.1.7
  415. winapi@0.2.8
  416. winapi@0.3.9
  417. winapi-build@0.1.1
  418. winapi-i686-pc-windows-gnu@0.4.0
  419. winapi-util@0.1.6
  420. winapi-x86_64-pc-windows-gnu@0.4.0
  421. windows-core@0.51.1
  422. windows-sys@0.45.0
  423. windows-sys@0.48.0
  424. windows-sys@0.52.0
  425. windows-targets@0.42.2
  426. windows-targets@0.48.5
  427. windows-targets@0.52.0
  428. windows_aarch64_gnullvm@0.42.2
  429. windows_aarch64_gnullvm@0.48.5
  430. windows_aarch64_gnullvm@0.52.0
  431. windows_aarch64_msvc@0.42.2
  432. windows_aarch64_msvc@0.48.5
  433. windows_aarch64_msvc@0.52.0
  434. windows_i686_gnu@0.42.2
  435. windows_i686_gnu@0.48.5
  436. windows_i686_gnu@0.52.0
  437. windows_i686_msvc@0.42.2
  438. windows_i686_msvc@0.48.5
  439. windows_i686_msvc@0.52.0
  440. windows_x86_64_gnu@0.42.2
  441. windows_x86_64_gnu@0.48.5
  442. windows_x86_64_gnu@0.52.0
  443. windows_x86_64_gnullvm@0.42.2
  444. windows_x86_64_gnullvm@0.48.5
  445. windows_x86_64_gnullvm@0.52.0
  446. windows_x86_64_msvc@0.42.2
  447. windows_x86_64_msvc@0.48.5
  448. windows_x86_64_msvc@0.52.0
  449. winnow@0.5.28
  450. winreg@0.50.0
  451. winres@0.1.12
  452. ws@0.9.2
  453. ws2_32-sys@0.2.1
  454. xattr@1.1.3
  455. xmlparser@0.13.6
  456. yada@0.5.0
  457. yaml-rust@0.4.5
  458. zerocopy@0.7.31
  459. zerocopy-derive@0.7.31
  460. zune-inflate@0.2.54
  461. "
  462. inherit cargo edo shell-completion
  463. DESCRIPTION="A fast static site generator with everything built-in"
  464. HOMEPAGE="
  465. https://www.getzola.org/
  466. https://github.com/getzola/zola
  467. "
  468. SRC_URI="
  469. ${CARGO_CRATE_URIS}
  470. https://github.com/getzola/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
  471. "
  472. LICENSE="MIT"
  473. # Dependent crate licenses
  474. LICENSE+="
  475. Apache-2.0 BSD-2 BSD CC0-1.0 ISC MIT MPL-2.0 Unicode-DFS-2016 ZLIB
  476. "
  477. SLOT="0"
  478. KEYWORDS="amd64 ~x86"
  479. DEPEND="dev-libs/libsass"
  480. RDEPEND="${DEPEND}"
  481. QA_PRESTRIPPED="usr/bin/${PN}"
  482. src_install() {
  483. cargo_src_install
  484. local zola="${ED}/usr/bin/zola"
  485. edo "${zola}" completion bash | newbashcomp - "${PN}.bash"
  486. edo "${zola}" completion fish | newfishcomp - "${PN}.fish"
  487. edo "${zola}" completion zsh | newzshcomp - "_${PN}"
  488. }