hexyl-0.14.0.ebuild 1.8 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586878889909192939495
  1. # Copyright 2017-2023 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. CRATES="
  5. aho-corasick@1.0.4
  6. anstream@0.3.2
  7. anstyle@1.0.1
  8. anstyle-parse@0.2.1
  9. anstyle-query@1.0.0
  10. anstyle-wincon@1.0.2
  11. anyhow@1.0.75
  12. assert_cmd@2.0.12
  13. autocfg@1.1.0
  14. bitflags@1.3.2
  15. bitflags@2.4.0
  16. bstr@1.6.0
  17. cc@1.0.83
  18. clap@4.3.23
  19. clap_builder@4.3.23
  20. clap_lex@0.5.0
  21. colorchoice@1.0.0
  22. const_format@0.2.31
  23. const_format_proc_macros@0.2.31
  24. diff@0.1.13
  25. difflib@0.4.0
  26. doc-comment@0.3.3
  27. either@1.9.0
  28. errno@0.3.2
  29. errno-dragonfly@0.1.2
  30. float-cmp@0.9.0
  31. hermit-abi@0.3.2
  32. io-lifetimes@1.0.11
  33. is-terminal@0.4.9
  34. is_ci@1.1.1
  35. itertools@0.10.5
  36. libc@0.2.147
  37. linux-raw-sys@0.3.8
  38. linux-raw-sys@0.4.5
  39. memchr@2.5.0
  40. normalize-line-endings@0.3.0
  41. num-traits@0.2.16
  42. once_cell@1.18.0
  43. owo-colors@3.5.0
  44. predicates@3.0.3
  45. predicates-core@1.0.6
  46. predicates-tree@1.0.9
  47. pretty_assertions@1.4.0
  48. proc-macro2@1.0.66
  49. quote@1.0.33
  50. regex@1.9.3
  51. regex-automata@0.3.6
  52. regex-syntax@0.7.4
  53. rustix@0.37.23
  54. rustix@0.38.8
  55. serde@1.0.185
  56. strsim@0.10.0
  57. supports-color@2.0.0
  58. syn@2.0.29
  59. terminal_size@0.2.6
  60. termtree@0.4.1
  61. thiserror@1.0.47
  62. thiserror-impl@1.0.47
  63. unicode-ident@1.0.11
  64. unicode-xid@0.2.4
  65. utf8parse@0.2.1
  66. wait-timeout@0.2.0
  67. windows-sys@0.48.0
  68. windows-targets@0.48.5
  69. windows_aarch64_gnullvm@0.48.5
  70. windows_aarch64_msvc@0.48.5
  71. windows_i686_gnu@0.48.5
  72. windows_i686_msvc@0.48.5
  73. windows_x86_64_gnu@0.48.5
  74. windows_x86_64_gnullvm@0.48.5
  75. windows_x86_64_msvc@0.48.5
  76. yansi@0.5.1
  77. ${PN}@${PV}
  78. "
  79. inherit cargo
  80. DESCRIPTION="A command-line hex viewer"
  81. HOMEPAGE="https://github.com/sharkdp/hexyl"
  82. SRC_URI="${CARGO_CRATE_URIS}"
  83. LICENSE="|| ( Apache-2.0 MIT )"
  84. # Dependent crate licenses
  85. LICENSE+=" Apache-2.0 ISC MIT Unicode-DFS-2016 ZLIB"
  86. SLOT="0"
  87. KEYWORDS="amd64"
  88. RESTRICT="mirror"