bandwhich-0.22.2.ebuild 6.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316
  1. # Copyright 2023-2024 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. CRATES="
  5. addr2line@0.21.0
  6. adler@1.0.2
  7. aes@0.8.3
  8. ahash@0.8.7
  9. aho-corasick@1.1.2
  10. allocator-api2@0.2.16
  11. android-tzdata@0.1.1
  12. android_system_properties@0.1.5
  13. anstream@0.6.11
  14. anstyle@1.0.4
  15. anstyle-parse@0.2.3
  16. anstyle-query@1.0.2
  17. anstyle-wincon@3.0.2
  18. anyhow@1.0.79
  19. async-trait@0.1.77
  20. autocfg@1.1.0
  21. backtrace@0.3.69
  22. base64ct@1.6.0
  23. bitflags@1.3.2
  24. bitflags@2.4.2
  25. block-buffer@0.10.4
  26. bumpalo@3.14.0
  27. byteorder@1.5.0
  28. bytes@1.5.0
  29. bzip2@0.4.4
  30. bzip2-sys@0.1.11+1.0.8
  31. cassowary@0.3.0
  32. cc@1.0.83
  33. cfg-if@1.0.0
  34. chrono@0.4.33
  35. cipher@0.4.4
  36. clap@4.4.18
  37. clap-verbosity-flag@2.1.2
  38. clap_builder@4.4.18
  39. clap_complete@4.4.9
  40. clap_derive@4.4.7
  41. clap_lex@0.6.0
  42. clap_mangen@0.2.17
  43. colorchoice@1.0.0
  44. console@0.15.8
  45. constant_time_eq@0.1.5
  46. core-foundation@0.9.4
  47. core-foundation-sys@0.8.6
  48. cpufeatures@0.2.12
  49. crc32fast@1.3.2
  50. crossbeam-deque@0.8.5
  51. crossbeam-epoch@0.9.18
  52. crossbeam-utils@0.8.19
  53. crossterm@0.27.0
  54. crossterm_winapi@0.9.1
  55. crypto-common@0.1.6
  56. data-encoding@2.5.0
  57. deranged@0.3.11
  58. derivative@2.2.0
  59. derive-new@0.5.9
  60. digest@0.10.7
  61. either@1.9.0
  62. encode_unicode@0.3.6
  63. enum-as-inner@0.6.0
  64. errno@0.3.8
  65. fastrand@2.0.1
  66. flate2@1.0.28
  67. foreign-types@0.3.2
  68. foreign-types-shared@0.1.1
  69. form_urlencoded@1.2.1
  70. futures@0.3.30
  71. futures-channel@0.3.30
  72. futures-core@0.3.30
  73. futures-executor@0.3.30
  74. futures-io@0.3.30
  75. futures-macro@0.3.30
  76. futures-sink@0.3.30
  77. futures-task@0.3.30
  78. futures-timer@3.0.2
  79. futures-util@0.3.30
  80. generic-array@0.14.7
  81. getrandom@0.2.12
  82. gimli@0.28.1
  83. glob@0.3.1
  84. hashbrown@0.14.3
  85. heck@0.4.1
  86. hermit-abi@0.3.4
  87. hex@0.4.3
  88. hmac@0.12.1
  89. hostname@0.3.1
  90. http_req@0.10.2
  91. iana-time-zone@0.1.59
  92. iana-time-zone-haiku@0.1.2
  93. idna@0.4.0
  94. idna@0.5.0
  95. indoc@2.0.4
  96. inout@0.1.3
  97. insta@1.34.0
  98. ipconfig@0.3.2
  99. ipnet@2.9.0
  100. ipnetwork@0.19.0
  101. ipnetwork@0.20.0
  102. itertools@0.12.0
  103. itoa@1.0.10
  104. jobserver@0.1.27
  105. js-sys@0.3.67
  106. lazy_static@1.4.0
  107. libc@0.2.152
  108. linked-hash-map@0.5.6
  109. linux-raw-sys@0.4.13
  110. lock_api@0.4.11
  111. log@0.4.20
  112. lru@0.12.1
  113. lru-cache@0.1.2
  114. match_cfg@0.1.0
  115. memchr@2.7.1
  116. miniz_oxide@0.7.1
  117. mio@0.8.10
  118. native-tls@0.2.11
  119. netstat2@0.9.1
  120. no-std-net@0.6.0
  121. ntapi@0.4.1
  122. num-derive@0.3.3
  123. num-traits@0.2.17
  124. num_cpus@1.16.0
  125. num_threads@0.1.6
  126. object@0.32.2
  127. once_cell@1.19.0
  128. openssl@0.10.63
  129. openssl-macros@0.1.1
  130. openssl-probe@0.1.5
  131. openssl-sys@0.9.99
  132. packet-builder@0.7.0
  133. parking_lot@0.12.1
  134. parking_lot_core@0.9.9
  135. password-hash@0.4.2
  136. paste@1.0.14
  137. pbkdf2@0.11.0
  138. percent-encoding@2.3.1
  139. pin-project-lite@0.2.13
  140. pin-utils@0.1.0
  141. pkg-config@0.3.29
  142. pnet@0.31.0
  143. pnet@0.34.0
  144. pnet_base@0.31.0
  145. pnet_base@0.34.0
  146. pnet_datalink@0.31.0
  147. pnet_datalink@0.34.0
  148. pnet_macros@0.31.0
  149. pnet_macros@0.34.0
  150. pnet_macros_support@0.31.0
  151. pnet_macros_support@0.34.0
  152. pnet_packet@0.31.0
  153. pnet_packet@0.34.0
  154. pnet_sys@0.31.0
  155. pnet_sys@0.34.0
  156. pnet_transport@0.31.0
  157. pnet_transport@0.34.0
  158. powerfmt@0.2.0
  159. ppv-lite86@0.2.17
  160. proc-macro2@1.0.78
  161. procfs@0.16.0
  162. procfs-core@0.16.0
  163. quick-error@1.2.3
  164. quote@1.0.35
  165. rand@0.8.5
  166. rand_chacha@0.3.1
  167. rand_core@0.6.4
  168. ratatui@0.25.0
  169. rayon@1.8.1
  170. rayon-core@1.12.1
  171. redox_syscall@0.4.1
  172. regex@1.10.3
  173. regex-automata@0.4.5
  174. regex-syntax@0.8.2
  175. relative-path@1.9.2
  176. resolv-conf@0.7.0
  177. roff@0.2.1
  178. rstest@0.18.2
  179. rstest_macros@0.18.2
  180. rustc-demangle@0.1.23
  181. rustc_version@0.4.0
  182. rustix@0.38.30
  183. rustversion@1.0.14
  184. schannel@0.1.23
  185. scopeguard@1.2.0
  186. security-framework@2.9.2
  187. security-framework-sys@2.9.1
  188. semver@1.0.21
  189. serde@1.0.196
  190. serde_derive@1.0.196
  191. sha1@0.10.6
  192. sha2@0.10.8
  193. signal-hook@0.3.17
  194. signal-hook-mio@0.2.3
  195. signal-hook-registry@1.4.1
  196. similar@2.4.0
  197. simplelog@0.12.1
  198. slab@0.4.9
  199. smallvec@1.13.1
  200. socket2@0.5.5
  201. stability@0.1.1
  202. strsim@0.10.0
  203. strum@0.25.0
  204. strum_macros@0.25.3
  205. subtle@2.5.0
  206. syn@1.0.109
  207. syn@2.0.48
  208. sysinfo@0.30.5
  209. tempfile@3.9.0
  210. termcolor@1.1.3
  211. thiserror@1.0.56
  212. thiserror-impl@1.0.56
  213. time@0.3.31
  214. time-core@0.1.2
  215. time-macros@0.2.16
  216. tinyvec@1.6.0
  217. tinyvec_macros@0.1.1
  218. tokio@1.35.1
  219. tracing@0.1.40
  220. tracing-attributes@0.1.27
  221. tracing-core@0.1.32
  222. trust-dns-proto@0.23.2
  223. trust-dns-resolver@0.23.2
  224. typenum@1.17.0
  225. unicase@2.7.0
  226. unicode-bidi@0.3.15
  227. unicode-ident@1.0.12
  228. unicode-normalization@0.1.22
  229. unicode-segmentation@1.10.1
  230. unicode-width@0.1.11
  231. url@2.5.0
  232. utf8parse@0.2.1
  233. vcpkg@0.2.15
  234. version_check@0.9.4
  235. wasi@0.11.0+wasi-snapshot-preview1
  236. wasm-bindgen@0.2.90
  237. wasm-bindgen-backend@0.2.90
  238. wasm-bindgen-macro@0.2.90
  239. wasm-bindgen-macro-support@0.2.90
  240. wasm-bindgen-shared@0.2.90
  241. widestring@1.0.2
  242. winapi@0.3.9
  243. winapi-i686-pc-windows-gnu@0.4.0
  244. winapi-util@0.1.6
  245. winapi-x86_64-pc-windows-gnu@0.4.0
  246. windows@0.52.0
  247. windows-core@0.52.0
  248. windows-sys@0.48.0
  249. windows-sys@0.52.0
  250. windows-targets@0.48.5
  251. windows-targets@0.52.0
  252. windows_aarch64_gnullvm@0.48.5
  253. windows_aarch64_gnullvm@0.52.0
  254. windows_aarch64_msvc@0.48.5
  255. windows_aarch64_msvc@0.52.0
  256. windows_i686_gnu@0.48.5
  257. windows_i686_gnu@0.52.0
  258. windows_i686_msvc@0.48.5
  259. windows_i686_msvc@0.52.0
  260. windows_x86_64_gnu@0.48.5
  261. windows_x86_64_gnu@0.52.0
  262. windows_x86_64_gnullvm@0.48.5
  263. windows_x86_64_gnullvm@0.52.0
  264. windows_x86_64_msvc@0.48.5
  265. windows_x86_64_msvc@0.52.0
  266. winreg@0.50.0
  267. yaml-rust@0.4.5
  268. zerocopy@0.7.32
  269. zerocopy-derive@0.7.32
  270. zip@0.6.6
  271. zstd@0.11.2+zstd.1.5.2
  272. zstd-safe@5.0.2+zstd.1.5.2
  273. zstd-sys@2.0.9+zstd.1.5.5
  274. ${PN}@${PV}
  275. "
  276. inherit cargo fcaps shell-completion
  277. DESCRIPTION="Terminal bandwidth utilization tool"
  278. HOMEPAGE="
  279. https://crates.io/crates/bandwhich
  280. https://github.com/imsnif/bandwhich
  281. "
  282. SRC_URI="${CARGO_CRATE_URIS}"
  283. LICENSE="MIT"
  284. # Dependent crate licenses
  285. LICENSE+=" Apache-2.0 BSD CC0-1.0 MIT Unicode-DFS-2016"
  286. SLOT="0"
  287. KEYWORDS="amd64"
  288. FILECAPS=(
  289. cap_sys_ptrace,cap_dac_read_search,cap_net_raw,cap_net_admin+ep "usr/bin/${PN}"
  290. )
  291. src_prepare() {
  292. export BANDWHICH_GEN_DIR="${T}/bandwhich-gen-dir"
  293. mkdir -p "${BANDWHICH_GEN_DIR}"
  294. default
  295. }
  296. src_install() {
  297. cargo_src_install
  298. doman "${BANDWHICH_GEN_DIR}/${PN}.1"
  299. dobashcomp "${BANDWHICH_GEN_DIR}/${PN}.bash"
  300. dofishcomp "${BANDWHICH_GEN_DIR}/${PN}.fish"
  301. dozshcomp "${BANDWHICH_GEN_DIR}/_${PN}"
  302. }