interface99-1.0.1.ebuild 565 B

12345678910111213141516171819202122232425
  1. # Copyright 2021-2023 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. DESCRIPTION="Zero-boilerplate interfaces for C99"
  5. HOMEPAGE="https://github.com/Hirrolot/interface99"
  6. SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  7. LICENSE="MIT"
  8. SLOT="0"
  9. KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x64-macos"
  10. DEPEND=">=dev-lang/metalang99-1.13.2"
  11. RDEPEND="${DEPEND}"
  12. src_install() {
  13. local DOCS=( README.md examples/ )
  14. doheader "${PN}.h"
  15. rm -- examples/.gitignore || die
  16. einstalldocs
  17. }