urwid-2.2.3.ebuild 815 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright 1999-2024 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. DISTUTILS_EXT=1
  5. DISTUTILS_USE_PEP517=setuptools
  6. PYTHON_COMPAT=( python3_{10..12} )
  7. PYTHON_REQ_USE="ncurses"
  8. inherit distutils-r1 optfeature pypi
  9. DESCRIPTION="Curses-based user interface library for Python"
  10. HOMEPAGE="
  11. https://urwid.org/
  12. https://pypi.org/project/urwid/
  13. https://github.com/urwid/urwid/
  14. "
  15. LICENSE="LGPL-2.1"
  16. SLOT="0"
  17. KEYWORDS="~alpha amd64 arm arm64 ~ia64 ~loong ~mips ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux"
  18. IUSE="examples"
  19. distutils_enable_tests unittest
  20. python_test() {
  21. rm -rf urwid || die
  22. eunittest
  23. }
  24. python_install_all() {
  25. use examples && dodoc -r examples
  26. distutils-r1_python_install_all
  27. }
  28. pkg_postinst() {
  29. optfeature "Trio event loop" "dev-python/trio"
  30. }