lemonbar-1.5-r1.ebuild 616 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 2021-2024 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. DESCRIPTION="A featherweight, lemon-scented, bar based on xcb"
  5. HOMEPAGE="https://github.com/LemonBoy/bar"
  6. SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  7. S="${WORKDIR}/${P##lemon}"
  8. LICENSE="MIT"
  9. SLOT="0"
  10. KEYWORDS="amd64 ~x86"
  11. IUSE="doc"
  12. DEPEND="x11-libs/libxcb"
  13. RDEPEND="${DEPEND}"
  14. BDEPEND="doc? ( dev-lang/perl )"
  15. PATCHES=(
  16. "${FILESDIR}/make-bar-always-below-other-windows.patch"
  17. )
  18. src_compile() {
  19. emake all $(usev doc)
  20. }
  21. src_install() {
  22. dobin "${PN}"
  23. use doc && doman "${PN}.1"
  24. }