bandwhich-0.23.1.ebuild 6.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343
  1. # Copyright 2023-2024 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. CRATES="
  5. addr2line@0.24.2
  6. adler2@2.0.0
  7. aes@0.8.4
  8. aho-corasick@1.1.3
  9. allocator-api2@0.2.18
  10. android-tzdata@0.1.1
  11. android_system_properties@0.1.5
  12. anstream@0.6.15
  13. anstyle@1.0.8
  14. anstyle-parse@0.2.5
  15. anstyle-query@1.1.1
  16. anstyle-wincon@3.0.4
  17. anyhow@1.0.89
  18. arbitrary@1.3.2
  19. async-trait@0.1.83
  20. autocfg@1.4.0
  21. backtrace@0.3.74
  22. bitflags@1.3.2
  23. bitflags@2.6.0
  24. block-buffer@0.10.4
  25. bumpalo@3.16.0
  26. byteorder@1.5.0
  27. bytes@1.7.2
  28. bzip2@0.4.4
  29. bzip2-sys@0.1.11+1.0.8
  30. cassowary@0.3.0
  31. castaway@0.2.3
  32. cc@1.1.28
  33. cfg-if@1.0.0
  34. chrono@0.4.38
  35. cipher@0.4.4
  36. clap@4.5.19
  37. clap-verbosity-flag@2.2.2
  38. clap_builder@4.5.19
  39. clap_complete@4.5.32
  40. clap_derive@4.5.18
  41. clap_lex@0.7.2
  42. clap_mangen@0.2.23
  43. colorchoice@1.0.2
  44. compact_str@0.8.0
  45. console@0.15.8
  46. constant_time_eq@0.3.1
  47. core-foundation@0.9.4
  48. core-foundation-sys@0.8.7
  49. cpufeatures@0.2.14
  50. crc@3.2.1
  51. crc-catalog@2.4.0
  52. crc32fast@1.4.2
  53. crossbeam-deque@0.8.5
  54. crossbeam-epoch@0.9.18
  55. crossbeam-utils@0.8.20
  56. crossterm@0.28.1
  57. crossterm_winapi@0.9.1
  58. crypto-common@0.1.6
  59. data-encoding@2.6.0
  60. deflate64@0.1.9
  61. deranged@0.3.11
  62. derivative@2.2.0
  63. derive-new@0.5.9
  64. derive_arbitrary@1.3.2
  65. digest@0.10.7
  66. displaydoc@0.2.5
  67. either@1.13.0
  68. encode_unicode@0.3.6
  69. enum-as-inner@0.6.1
  70. equivalent@1.0.1
  71. errno@0.3.9
  72. fastrand@2.1.1
  73. flate2@1.0.34
  74. foldhash@0.1.3
  75. foreign-types@0.3.2
  76. foreign-types-shared@0.1.1
  77. form_urlencoded@1.2.1
  78. futures@0.3.31
  79. futures-channel@0.3.31
  80. futures-core@0.3.31
  81. futures-executor@0.3.31
  82. futures-io@0.3.31
  83. futures-macro@0.3.31
  84. futures-sink@0.3.31
  85. futures-task@0.3.31
  86. futures-timer@3.0.3
  87. futures-util@0.3.31
  88. generic-array@0.14.7
  89. getrandom@0.2.15
  90. gimli@0.31.1
  91. glob@0.3.1
  92. hashbrown@0.15.0
  93. heck@0.5.0
  94. hermit-abi@0.3.9
  95. hex@0.4.3
  96. hmac@0.12.1
  97. hostname@0.3.1
  98. http_req@0.12.0
  99. iana-time-zone@0.1.61
  100. iana-time-zone-haiku@0.1.2
  101. idna@0.4.0
  102. idna@0.5.0
  103. indexmap@2.6.0
  104. inout@0.1.3
  105. insta@1.40.0
  106. instability@0.3.2
  107. ipconfig@0.3.2
  108. ipnet@2.10.1
  109. ipnetwork@0.19.0
  110. ipnetwork@0.20.0
  111. is_terminal_polyfill@1.70.1
  112. itertools@0.13.0
  113. itoa@1.0.11
  114. jobserver@0.1.32
  115. js-sys@0.3.70
  116. lazy_static@1.5.0
  117. libc@0.2.159
  118. linked-hash-map@0.5.6
  119. linux-raw-sys@0.4.14
  120. lock_api@0.4.12
  121. lockfree-object-pool@0.1.6
  122. log@0.4.22
  123. lru@0.12.5
  124. lru-cache@0.1.2
  125. lzma-rs@0.3.0
  126. match_cfg@0.1.0
  127. memchr@2.7.4
  128. miniz_oxide@0.8.0
  129. mio@1.0.2
  130. native-tls@0.2.12
  131. netstat2@0.9.1
  132. no-std-net@0.6.0
  133. ntapi@0.4.1
  134. num-conv@0.1.0
  135. num-derive@0.3.3
  136. num-traits@0.2.19
  137. num_threads@0.1.7
  138. object@0.36.5
  139. once_cell@1.20.2
  140. openssl@0.10.66
  141. openssl-macros@0.1.1
  142. openssl-probe@0.1.5
  143. openssl-sys@0.9.103
  144. packet-builder@0.7.0
  145. parking_lot@0.12.3
  146. parking_lot_core@0.9.10
  147. paste@1.0.15
  148. pbkdf2@0.12.2
  149. percent-encoding@2.3.1
  150. pin-project-lite@0.2.14
  151. pin-utils@0.1.0
  152. pkg-config@0.3.31
  153. pnet@0.31.0
  154. pnet@0.34.0
  155. pnet_base@0.31.0
  156. pnet_base@0.34.0
  157. pnet_datalink@0.31.0
  158. pnet_datalink@0.34.0
  159. pnet_macros@0.31.0
  160. pnet_macros@0.34.0
  161. pnet_macros_support@0.31.0
  162. pnet_macros_support@0.34.0
  163. pnet_packet@0.31.0
  164. pnet_packet@0.34.0
  165. pnet_sys@0.31.0
  166. pnet_sys@0.34.0
  167. pnet_transport@0.31.0
  168. pnet_transport@0.34.0
  169. powerfmt@0.2.0
  170. ppv-lite86@0.2.20
  171. proc-macro-crate@3.2.0
  172. proc-macro2@1.0.87
  173. procfs@0.17.0
  174. procfs-core@0.17.0
  175. quick-error@1.2.3
  176. quote@1.0.37
  177. rand@0.8.5
  178. rand_chacha@0.3.1
  179. rand_core@0.6.4
  180. ratatui@0.28.1
  181. rayon@1.10.0
  182. rayon-core@1.12.1
  183. redox_syscall@0.5.7
  184. regex@1.11.0
  185. regex-automata@0.4.8
  186. regex-syntax@0.8.5
  187. relative-path@1.9.3
  188. resolv-conf@0.7.0
  189. roff@0.2.2
  190. rstest@0.23.0
  191. rstest_macros@0.23.0
  192. rustc-demangle@0.1.24
  193. rustc_version@0.4.1
  194. rustix@0.38.37
  195. rustversion@1.0.17
  196. ryu@1.0.18
  197. schannel@0.1.26
  198. scopeguard@1.2.0
  199. security-framework@2.11.1
  200. security-framework-sys@2.12.0
  201. semver@1.0.23
  202. serde@1.0.210
  203. serde_derive@1.0.210
  204. sha1@0.10.6
  205. shlex@1.3.0
  206. signal-hook@0.3.17
  207. signal-hook-mio@0.2.4
  208. signal-hook-registry@1.4.2
  209. simd-adler32@0.3.7
  210. similar@2.6.0
  211. simplelog@0.12.2
  212. slab@0.4.9
  213. smallvec@1.13.2
  214. socket2@0.5.7
  215. static_assertions@1.1.0
  216. strsim@0.11.1
  217. strum@0.26.3
  218. strum_macros@0.26.4
  219. subtle@2.6.1
  220. syn@1.0.109
  221. syn@2.0.79
  222. sysinfo@0.32.0
  223. tempfile@3.13.0
  224. termcolor@1.4.1
  225. thiserror@1.0.64
  226. thiserror-impl@1.0.64
  227. time@0.3.36
  228. time-core@0.1.2
  229. time-macros@0.2.18
  230. tinyvec@1.8.0
  231. tinyvec_macros@0.1.1
  232. tokio@1.40.0
  233. toml_datetime@0.6.8
  234. toml_edit@0.22.22
  235. tracing@0.1.40
  236. tracing-attributes@0.1.27
  237. tracing-core@0.1.32
  238. trust-dns-proto@0.23.2
  239. trust-dns-resolver@0.23.2
  240. typenum@1.17.0
  241. unicase@2.7.0
  242. unicode-bidi@0.3.17
  243. unicode-ident@1.0.13
  244. unicode-normalization@0.1.24
  245. unicode-segmentation@1.12.0
  246. unicode-truncate@1.1.0
  247. unicode-width@0.1.14
  248. unicode-width@0.2.0
  249. url@2.5.2
  250. utf8parse@0.2.2
  251. vcpkg@0.2.15
  252. version_check@0.9.5
  253. wasi@0.11.0+wasi-snapshot-preview1
  254. wasm-bindgen@0.2.93
  255. wasm-bindgen-backend@0.2.93
  256. wasm-bindgen-macro@0.2.93
  257. wasm-bindgen-macro-support@0.2.93
  258. wasm-bindgen-shared@0.2.93
  259. widestring@1.1.0
  260. winapi@0.3.9
  261. winapi-i686-pc-windows-gnu@0.4.0
  262. winapi-util@0.1.9
  263. winapi-x86_64-pc-windows-gnu@0.4.0
  264. windows@0.57.0
  265. windows-core@0.52.0
  266. windows-core@0.57.0
  267. windows-implement@0.57.0
  268. windows-interface@0.57.0
  269. windows-result@0.1.2
  270. windows-sys@0.48.0
  271. windows-sys@0.52.0
  272. windows-sys@0.59.0
  273. windows-targets@0.48.5
  274. windows-targets@0.52.6
  275. windows_aarch64_gnullvm@0.48.5
  276. windows_aarch64_gnullvm@0.52.6
  277. windows_aarch64_msvc@0.48.5
  278. windows_aarch64_msvc@0.52.6
  279. windows_i686_gnu@0.48.5
  280. windows_i686_gnu@0.52.6
  281. windows_i686_gnullvm@0.52.6
  282. windows_i686_msvc@0.48.5
  283. windows_i686_msvc@0.52.6
  284. windows_x86_64_gnu@0.48.5
  285. windows_x86_64_gnu@0.52.6
  286. windows_x86_64_gnullvm@0.48.5
  287. windows_x86_64_gnullvm@0.52.6
  288. windows_x86_64_msvc@0.48.5
  289. windows_x86_64_msvc@0.52.6
  290. winnow@0.6.20
  291. winreg@0.50.0
  292. zerocopy@0.7.35
  293. zerocopy-derive@0.7.35
  294. zeroize@1.8.1
  295. zeroize_derive@1.4.2
  296. zip@2.2.0
  297. zopfli@0.8.1
  298. zstd@0.13.2
  299. zstd-safe@7.2.1
  300. zstd-sys@2.0.13+zstd.1.5.6
  301. ${PN}@${PV}
  302. "
  303. inherit cargo fcaps shell-completion
  304. DESCRIPTION="Terminal bandwidth utilization tool"
  305. HOMEPAGE="
  306. https://crates.io/crates/bandwhich
  307. https://github.com/imsnif/bandwhich
  308. "
  309. SRC_URI="${CARGO_CRATE_URIS}"
  310. LICENSE="MIT"
  311. # Dependent crate licenses
  312. LICENSE+=" Apache-2.0 BSD CC0-1.0 MIT Unicode-DFS-2016"
  313. SLOT="0"
  314. KEYWORDS="amd64"
  315. FILECAPS=(
  316. cap_sys_ptrace,cap_dac_read_search,cap_net_raw,cap_net_admin+ep "usr/bin/${PN}"
  317. )
  318. src_prepare() {
  319. export BANDWHICH_GEN_DIR="${T}/bandwhich-gen-dir"
  320. mkdir -p "${BANDWHICH_GEN_DIR}"
  321. default
  322. }
  323. src_install() {
  324. cargo_src_install
  325. doman "${BANDWHICH_GEN_DIR}/${PN}.1"
  326. dobashcomp "${BANDWHICH_GEN_DIR}/${PN}.bash"
  327. dofishcomp "${BANDWHICH_GEN_DIR}/${PN}.fish"
  328. dozshcomp "${BANDWHICH_GEN_DIR}/_${PN}"
  329. }