zsh-powerlevel10k-1.20.0.ebuild 915 B

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849
  1. # Copyright 2021-2024 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. MY_PN="${PN##zsh-}"
  5. DESCRIPTION="Theme for Zsh that emphasizes speed, flexibility and out-of-the-box experience"
  6. HOMEPAGE="https://github.com/romkatv/powerlevel10k"
  7. SRC_URI="https://github.com/romkatv/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  8. S="${WORKDIR}/${MY_PN}-${PV}"
  9. LICENSE="MIT"
  10. SLOT="0"
  11. KEYWORDS="amd64 ~arm ~arm64 ~ppc64 ~x86"
  12. DEPEND="
  13. app-shells/zsh
  14. app-shells/gitstatus
  15. "
  16. RDEPEND="${DEPEND}"
  17. src_prepare() {
  18. sed -i Makefile -e '/gitstatus/d'
  19. default
  20. }
  21. src_compile() {
  22. emake pkg
  23. }
  24. src_install() {
  25. local DOCS=( {README,font}.md )
  26. insinto "/usr/share/zsh/site-contrib/${MY_PN}"
  27. doins -r config/
  28. doins -r internal/
  29. doins prompt_*_setup
  30. doins powerlevel*.zsh-theme{,.zwc}
  31. dosym ../../../gitstatus \
  32. "/usr/share/zsh/site-contrib/${MY_PN}/gitstatus"
  33. einstalldocs
  34. }