newsboat-2.32.ebuild 4.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206
  1. # Copyright 2017-2023 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. # private crates:
  5. # libnewsboat
  6. # libnewsboat-ffi
  7. # regex-rs
  8. # strprintf
  9. CRATES="
  10. addr2line@0.19.0
  11. adler@1.0.2
  12. aho-corasick@0.7.20
  13. android-tzdata@0.1.1
  14. android_system_properties@0.1.5
  15. autocfg@1.1.0
  16. backtrace@0.3.67
  17. bit-set@0.5.3
  18. bit-vec@0.6.3
  19. bitflags@1.3.2
  20. bitflags@2.3.2
  21. block@0.1.6
  22. bumpalo@3.12.0
  23. byteorder@1.4.3
  24. cc@1.0.79
  25. cfg-if@1.0.0
  26. chrono@0.4.26
  27. codespan-reporting@0.11.1
  28. core-foundation-sys@0.8.3
  29. curl-sys@0.4.63+curl-8.1.2
  30. cxx@1.0.97
  31. cxx-build@1.0.97
  32. cxxbridge-flags@1.0.97
  33. cxxbridge-macro@1.0.97
  34. errno@0.3.1
  35. errno-dragonfly@0.1.2
  36. fastrand@1.9.0
  37. fnv@1.0.7
  38. form_urlencoded@1.2.0
  39. getrandom@0.2.8
  40. gettext-rs@0.7.0
  41. gettext-sys@0.21.3
  42. gimli@0.27.2
  43. hermit-abi@0.3.1
  44. home@0.5.5
  45. iana-time-zone@0.1.54
  46. iana-time-zone-haiku@0.1.1
  47. idna@0.4.0
  48. instant@0.1.12
  49. io-lifetimes@1.0.11
  50. js-sys@0.3.61
  51. lazy_static@1.4.0
  52. lexopt@0.3.0
  53. libc@0.2.146
  54. libm@0.2.6
  55. libz-sys@1.1.8
  56. link-cplusplus@1.0.8
  57. linux-raw-sys@0.3.8
  58. locale_config@0.3.0
  59. log@0.4.17
  60. malloc_buf@0.0.6
  61. md5@0.7.0
  62. memchr@2.5.0
  63. minimal-lexical@0.2.1
  64. miniz_oxide@0.6.2
  65. natord@1.0.9
  66. nom@7.1.3
  67. num-traits@0.2.15
  68. objc@0.2.7
  69. objc-foundation@0.1.1
  70. objc_id@0.1.1
  71. object@0.30.3
  72. once_cell@1.18.0
  73. percent-encoding@2.3.0
  74. pkg-config@0.3.26
  75. ppv-lite86@0.2.17
  76. proc-macro2@1.0.59
  77. proptest@1.1.0
  78. quick-error@1.2.3
  79. quick-error@2.0.1
  80. quote@1.0.26
  81. rand@0.8.5
  82. rand_chacha@0.3.1
  83. rand_core@0.6.4
  84. rand_xorshift@0.3.0
  85. redox_syscall@0.3.5
  86. regex@1.7.3
  87. regex-syntax@0.6.29
  88. rustc-demangle@0.1.22
  89. rustix@0.37.19
  90. rusty-fork@0.3.0
  91. scratch@1.0.5
  92. section_testing@0.0.5
  93. syn@1.0.109
  94. syn@2.0.12
  95. temp-dir@0.1.11
  96. tempfile@3.6.0
  97. termcolor@1.2.0
  98. tinyvec@1.6.0
  99. tinyvec_macros@0.1.1
  100. unarray@0.1.4
  101. unicode-bidi@0.3.13
  102. unicode-ident@1.0.8
  103. unicode-normalization@0.1.22
  104. unicode-width@0.1.10
  105. url@2.4.0
  106. vcpkg@0.2.15
  107. wait-timeout@0.2.0
  108. wasi@0.11.0+wasi-snapshot-preview1
  109. wasm-bindgen@0.2.84
  110. wasm-bindgen-backend@0.2.84
  111. wasm-bindgen-macro@0.2.84
  112. wasm-bindgen-macro-support@0.2.84
  113. wasm-bindgen-shared@0.2.84
  114. winapi@0.3.9
  115. winapi-i686-pc-windows-gnu@0.4.0
  116. winapi-util@0.1.5
  117. winapi-x86_64-pc-windows-gnu@0.4.0
  118. windows@0.46.0
  119. windows-sys@0.48.0
  120. windows-targets@0.42.2
  121. windows-targets@0.48.0
  122. windows_aarch64_gnullvm@0.42.2
  123. windows_aarch64_gnullvm@0.48.0
  124. windows_aarch64_msvc@0.42.2
  125. windows_aarch64_msvc@0.48.0
  126. windows_i686_gnu@0.42.2
  127. windows_i686_gnu@0.48.0
  128. windows_i686_msvc@0.42.2
  129. windows_i686_msvc@0.48.0
  130. windows_x86_64_gnu@0.42.2
  131. windows_x86_64_gnu@0.48.0
  132. windows_x86_64_gnullvm@0.42.2
  133. windows_x86_64_gnullvm@0.48.0
  134. windows_x86_64_msvc@0.42.2
  135. windows_x86_64_msvc@0.48.0
  136. xdg@2.5.0
  137. "
  138. inherit flag-o-matic toolchain-funcs cargo
  139. DESCRIPTION="An RSS/Atom feed reader for text terminals"
  140. HOMEPAGE="https://newsboat.org/ https://github.com/newsboat/newsboat"
  141. SRC_URI="
  142. https://newsboat.org/releases/${PV}/${P}.tar.xz
  143. ${CARGO_CRATE_URIS}
  144. "
  145. LICENSE="Apache-2.0 Apache-2.0-with-LLVM-exceptions Boost-1.0 BSD MIT Unlicense ZLIB"
  146. SLOT="0"
  147. KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
  148. IUSE="doc"
  149. RDEPEND="
  150. >=dev-db/sqlite-3.5:3
  151. >=dev-libs/json-c-0.11:=
  152. >=dev-libs/stfl-0.21
  153. >=net-misc/curl-7.21.6
  154. dev-libs/libxml2
  155. dev-libs/openssl:=
  156. sys-libs/ncurses:=[unicode(+)]
  157. sys-libs/zlib
  158. "
  159. DEPEND="${RDEPEND}
  160. sys-devel/gettext
  161. "
  162. BDEPEND="
  163. app-alternatives/awk
  164. doc? ( >=dev-ruby/asciidoctor-1.5.3 )
  165. virtual/pkgconfig
  166. >=virtual/rust-1.62.0
  167. "
  168. src_prepare() {
  169. default
  170. sed -i Makefile \
  171. -e '/^WARNFLAGS\s*=/s/-Werror//' \
  172. -e '/^BARE_CXXFLAGS\s*=/s/-[Og][^ ]\+//g'
  173. use doc || {
  174. sed -i Makefile \
  175. -e '/^all:/s/doc//' \
  176. -e '/^install:/s/install-docs//'
  177. }
  178. }
  179. src_configure() {
  180. filter-lto # bug #877657
  181. ./config.sh || die
  182. }
  183. src_compile() {
  184. export CARGO_HOME="${ECARGO_HOME}"
  185. emake prefix=/usr CXX="$(tc-getCXX)" \
  186. AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)"
  187. }
  188. src_test() {
  189. emake CC="${tc-getCC}" CXX="$(tc-getCXX)" AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)" check || die
  190. }
  191. src_install() {
  192. emake DESTDIR="${ED}" prefix=/usr docdir="/usr/share/doc/${PF}" install
  193. einstalldocs
  194. }