gitui-0.24.3.ebuild 5.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290
  1. # Copyright 2022-2023 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. AG_PV="${PV}"
  5. CRATES="
  6. addr2line@0.19.0
  7. adler@1.0.2
  8. aho-corasick@1.0.2
  9. android-tzdata@0.1.1
  10. android_system_properties@0.1.5
  11. anstream@0.5.0
  12. anstyle@1.0.2
  13. anstyle-parse@0.2.1
  14. anstyle-query@1.0.0
  15. anstyle-wincon@2.1.0
  16. anyhow@1.0.75
  17. autocfg@1.1.0
  18. backtrace@0.3.67
  19. base64@0.13.1
  20. bincode@1.3.3
  21. bit-set@0.5.3
  22. bit-vec@0.6.3
  23. bitflags@1.3.2
  24. bugreport@0.5.0
  25. bumpalo@3.12.0
  26. bwrap@1.3.0
  27. bytesize@1.3.0
  28. cassowary@0.3.0
  29. cc@1.0.79
  30. cfg-if@1.0.0
  31. chrono@0.4.30
  32. clap@4.4.2
  33. clap_builder@4.4.2
  34. clap_lex@0.5.1
  35. codespan-reporting@0.11.1
  36. colorchoice@1.0.0
  37. core-foundation-sys@0.8.3
  38. crc32fast@1.3.2
  39. crossbeam-channel@0.5.8
  40. crossbeam-deque@0.8.2
  41. crossbeam-epoch@0.9.13
  42. crossbeam-utils@0.8.14
  43. crossterm@0.26.1
  44. crossterm_winapi@0.9.0
  45. cxx@1.0.90
  46. cxx-build@1.0.90
  47. cxxbridge-flags@1.0.90
  48. cxxbridge-macro@1.0.90
  49. dashmap@5.4.0
  50. diff@0.1.13
  51. dirs@5.0.1
  52. dirs-sys@0.4.1
  53. easy-cast@0.5.2
  54. either@1.8.1
  55. env_logger@0.10.0
  56. errno@0.2.8
  57. errno-dragonfly@0.1.2
  58. fancy-regex@0.11.0
  59. fastrand@1.9.0
  60. filetime@0.2.20
  61. filetreelist@0.5.0
  62. flate2@1.0.25
  63. fnv@1.0.7
  64. form_urlencoded@1.2.0
  65. fsevent-sys@4.1.0
  66. futures@0.3.26
  67. futures-channel@0.3.26
  68. futures-core@0.3.26
  69. futures-executor@0.3.26
  70. futures-io@0.3.26
  71. futures-sink@0.3.26
  72. futures-task@0.3.26
  73. futures-util@0.3.26
  74. fuzzy-matcher@0.3.7
  75. getrandom@0.2.8
  76. gh-emoji@1.0.7
  77. gimli@0.27.3
  78. git-version@0.3.5
  79. git-version-macro@0.3.5
  80. git2@0.17.2
  81. hashbrown@0.12.3
  82. hermit-abi@0.3.2
  83. humantime@2.1.0
  84. iana-time-zone@0.1.53
  85. iana-time-zone-haiku@0.1.1
  86. idna@0.4.0
  87. indexmap@1.9.3
  88. inotify@0.9.6
  89. inotify-sys@0.1.5
  90. instant@0.1.12
  91. invalidstring@0.1.2
  92. io-lifetimes@1.0.5
  93. is-terminal@0.4.3
  94. itertools@0.11.0
  95. itoa@1.0.8
  96. jobserver@0.1.25
  97. js-sys@0.3.61
  98. kqueue@1.0.7
  99. kqueue-sys@1.0.3
  100. lazy_static@1.4.0
  101. libc@0.2.139
  102. libgit2-sys@0.15.2+1.6.4
  103. libssh2-sys@0.3.0
  104. libz-sys@1.1.8
  105. link-cplusplus@1.0.8
  106. linux-raw-sys@0.1.4
  107. lock_api@0.4.10
  108. log@0.4.20
  109. memchr@2.5.0
  110. memoffset@0.7.1
  111. miniz_oxide@0.6.2
  112. mio@0.8.5
  113. notify@5.2.0
  114. notify-debouncer-mini@0.2.1
  115. num-traits@0.2.15
  116. num_cpus@1.16.0
  117. object@0.30.3
  118. once_cell@1.18.0
  119. onig@6.4.0
  120. onig_sys@69.8.1
  121. openssl-probe@0.1.5
  122. openssl-src@300.1.3+3.1.2
  123. openssl-sys@0.9.93
  124. option-ext@0.2.0
  125. parking_lot@0.12.1
  126. parking_lot_core@0.9.7
  127. percent-encoding@2.3.0
  128. phf@0.11.1
  129. phf_shared@0.11.1
  130. pin-project-lite@0.2.9
  131. pin-utils@0.1.0
  132. pkg-config@0.3.26
  133. pretty_assertions@1.4.0
  134. proc-macro-error@1.0.4
  135. proc-macro-error-attr@1.0.4
  136. proc-macro-hack@0.5.20+deprecated
  137. proc-macro2@1.0.63
  138. quote@1.0.29
  139. ratatui@0.21.0
  140. rayon@1.7.0
  141. rayon-core@1.11.0
  142. redox_syscall@0.2.16
  143. redox_users@0.4.3
  144. regex@1.9.1
  145. regex-automata@0.3.4
  146. regex-syntax@0.7.4
  147. ron@0.8.0
  148. rustc-demangle@0.1.21
  149. rustix@0.36.8
  150. ryu@1.0.14
  151. same-file@1.0.6
  152. scopeguard@1.2.0
  153. scopetime@0.1.2
  154. scratch@1.0.3
  155. serde@1.0.156
  156. serde_derive@1.0.156
  157. serde_json@1.0.93
  158. serial_test@1.0.0
  159. serial_test_derive@1.0.0
  160. shell-escape@0.1.5
  161. shellexpand@3.1.0
  162. signal-hook@0.3.15
  163. signal-hook-mio@0.2.3
  164. signal-hook-registry@1.4.1
  165. simplelog@0.12.1
  166. siphasher@0.3.10
  167. slab@0.4.8
  168. smallvec@1.11.0
  169. strsim@0.10.0
  170. struct-patch@0.2.3
  171. struct-patch-derive@0.2.3
  172. syn@1.0.107
  173. syntect@5.1.0
  174. sys-info@0.9.1
  175. tempfile@3.4.0
  176. termcolor@1.2.0
  177. thiserror@1.0.39
  178. thiserror-impl@1.0.39
  179. thread_local@1.1.7
  180. time@0.3.22
  181. time-core@0.1.1
  182. time-macros@0.2.9
  183. tinyvec@1.6.0
  184. tinyvec_macros@0.1.1
  185. unicode-bidi@0.3.10
  186. unicode-ident@1.0.6
  187. unicode-normalization@0.1.22
  188. unicode-segmentation@1.10.1
  189. unicode-truncate@0.2.0
  190. unicode-width@0.1.10
  191. url@2.4.1
  192. utf8parse@0.2.1
  193. vcpkg@0.2.15
  194. version_check@0.9.4
  195. walkdir@2.3.3
  196. wasi@0.11.0+wasi-snapshot-preview1
  197. wasm-bindgen@0.2.84
  198. wasm-bindgen-backend@0.2.84
  199. wasm-bindgen-macro@0.2.84
  200. wasm-bindgen-macro-support@0.2.84
  201. wasm-bindgen-shared@0.2.84
  202. which@4.4.0
  203. winapi@0.3.9
  204. winapi-i686-pc-windows-gnu@0.4.0
  205. winapi-util@0.1.5
  206. winapi-x86_64-pc-windows-gnu@0.4.0
  207. windows-sys@0.42.0
  208. windows-sys@0.45.0
  209. windows-sys@0.48.0
  210. windows-targets@0.42.1
  211. windows-targets@0.48.1
  212. windows_aarch64_gnullvm@0.42.1
  213. windows_aarch64_gnullvm@0.48.0
  214. windows_aarch64_msvc@0.42.1
  215. windows_aarch64_msvc@0.48.0
  216. windows_i686_gnu@0.42.1
  217. windows_i686_gnu@0.48.0
  218. windows_i686_msvc@0.42.1
  219. windows_i686_msvc@0.48.0
  220. windows_x86_64_gnu@0.42.1
  221. windows_x86_64_gnu@0.48.0
  222. windows_x86_64_gnullvm@0.42.1
  223. windows_x86_64_gnullvm@0.48.0
  224. windows_x86_64_msvc@0.42.1
  225. windows_x86_64_msvc@0.48.0
  226. yansi@0.5.1
  227. asyncgit@${AG_PV}
  228. "
  229. inherit cargo
  230. DESCRIPTION="Blazing fast terminal-ui for git"
  231. HOMEPAGE="
  232. https://crates.io/crates/gitui
  233. https://github.com/extrawurst/gitui
  234. "
  235. SRC_URI="
  236. ${CARGO_CRATE_URIS}
  237. https://github.com/extrawurst/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
  238. "
  239. LICENSE="MIT"
  240. # Dependent crate licenses
  241. LICENSE+="
  242. Apache-2.0 BSD-2 BSD CDDL ISC MIT Unicode-DFS-2016
  243. || ( Artistic-2 CC0-1.0 )
  244. "
  245. SLOT="0"
  246. KEYWORDS="amd64 ~arm64 x86"
  247. IUSE="ghemoji trace-libgit"
  248. RDEPEND="
  249. >=dev-libs/libgit2-1.2.0:=
  250. trace-libgit? ( dev-libs/libgit2[trace(+)] )
  251. dev-libs/openssl
  252. "
  253. DEPEND="${RDEPEND}"
  254. RESTRICT="mirror"
  255. src_configure() {
  256. local myfeatures=(
  257. $(usev ghemoji)
  258. $(usev trace-libgit)
  259. regex-fancy
  260. )
  261. cargo_src_configure --no-default-features
  262. }
  263. src_install() {
  264. local DOCS=({README,KEY_CONFIG,THEMES}.md)
  265. cargo_src_install
  266. insinto "/usr/share/${P}/examples"
  267. doins vim_style_key_config.ron
  268. einstalldocs
  269. }
  270. pkg_postinst() {
  271. einfo "Example of vim keybindings config stored in '/usr/share/${P}/examples'"
  272. einfo 'to use it put example config in `$XDG_CONFIG_HOME/gitui/key_bindings.ron`'
  273. }