zsh-vi-mode-0.11.0.ebuild 665 B

1234567891011121314151617181920212223242526
  1. # Copyright 2021-2023 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. DESCRIPTION="A better and friendly vi(vim) mode plugin for ZSH."
  5. HOMEPAGE="https://github.com/jeffreytse/zsh-vi-mode"
  6. SRC_URI="
  7. https://github.com/jeffreytse/${PN}/archive/v${PV}.tar.gz
  8. -> ${P}.tar.gz
  9. "
  10. LICENSE="MIT"
  11. SLOT="0"
  12. KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
  13. DEPEND="app-shells/zsh"
  14. RDEPEND="${DEPEND}"
  15. src_install() {
  16. insinto "/usr/share/zsh/site-contrib/${PN}"
  17. doins "${PN}"{,.plugin}.zsh
  18. einstalldocs
  19. }