zsh-powerlevel10k-1.20.0.ebuild 914 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051
  1. # Copyright 2021 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=7
  4. MY_PN="${PN##zsh-}"
  5. DESCRIPTION="Theme for Zsh that emphasizes speed, flexibility and out-of-the-box experience"
  6. HOMEPAGE="https://github.com/romkatv/powerlevel10k"
  7. SRC_URI="
  8. https://github.com/romkatv/${MY_PN}/archive/v${PV}.tar.gz
  9. -> ${P}.tar.gz"
  10. LICENSE="MIT"
  11. SLOT="0"
  12. KEYWORDS="amd64 ~arm ~arm64 ~ppc64 ~x86"
  13. DEPEND="
  14. app-shells/zsh
  15. app-shells/gitstatus
  16. "
  17. RDEPEND="${DEPEND}"
  18. S="${WORKDIR}/${MY_PN}-${PV}"
  19. src_prepare() {
  20. sed -i Makefile -e '/gitstatus/d'
  21. default
  22. }
  23. src_compile() {
  24. emake pkg
  25. }
  26. src_install() {
  27. local DOCS=( {README,font}.md )
  28. insinto "/usr/share/zsh/site-contrib/${MY_PN}"
  29. doins -r config/
  30. doins -r internal/
  31. doins prompt_*_setup
  32. doins powerlevel*.zsh-theme{,.zwc}
  33. dosym ../../../gitstatus \
  34. "/usr/share/zsh/site-contrib/${MY_PN}/gitstatus"
  35. einstalldocs
  36. }