gpg-tui-0.10.0.ebuild 5.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284
  1. # Copyright 2017-2023 Gentoo Authors
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=8
  4. CRATES="
  5. addr2line@0.21.0
  6. adler@1.0.2
  7. android-tzdata@0.1.1
  8. android_system_properties@0.1.5
  9. anstream@0.5.0
  10. anstyle@1.0.2
  11. anstyle-parse@0.2.1
  12. anstyle-query@1.0.0
  13. anstyle-wincon@2.1.0
  14. anyhow@1.0.75
  15. autocfg@1.1.0
  16. backtrace@0.3.69
  17. better-panic@0.3.0
  18. bitflags@1.3.2
  19. bitflags@2.4.0
  20. block@0.1.6
  21. block-buffer@0.10.4
  22. build-rs@0.1.2
  23. bumpalo@3.13.0
  24. bytemuck@1.14.0
  25. byteorder@1.4.3
  26. cassowary@0.3.0
  27. cc@1.0.83
  28. cfg-expr@0.15.5
  29. cfg-if@1.0.0
  30. chrono@0.4.30
  31. clap@4.4.2
  32. clap_builder@4.4.2
  33. clap_complete@4.4.1
  34. clap_derive@4.4.2
  35. clap_lex@0.5.1
  36. clipboard-win@3.1.1
  37. color_quant@1.1.0
  38. colorchoice@1.0.0
  39. colorsys@0.6.7
  40. console@0.15.7
  41. conv@0.3.3
  42. copypasta@0.8.2
  43. copypasta-ext@0.4.4
  44. core-foundation-sys@0.8.4
  45. cpufeatures@0.2.9
  46. crossterm@0.27.0
  47. crossterm_winapi@0.9.1
  48. crypto-common@0.1.6
  49. cstr-argument@0.1.2
  50. custom_derive@0.1.7
  51. diff@0.1.13
  52. digest@0.10.7
  53. dirs@5.0.1
  54. dirs-next@2.0.0
  55. dirs-sys@0.4.1
  56. dirs-sys-next@0.1.2
  57. dlib@0.5.2
  58. downcast-rs@1.2.0
  59. either@1.9.0
  60. encode_unicode@0.3.6
  61. equivalent@1.0.1
  62. errno@0.3.3
  63. errno-dragonfly@0.1.2
  64. generic-array@0.14.7
  65. gethostname@0.2.3
  66. getrandom@0.2.10
  67. gimli@0.28.0
  68. gpg-error@0.6.0
  69. gpgme@0.11.0
  70. gpgme-sys@0.11.0
  71. hashbrown@0.14.0
  72. heck@0.4.1
  73. hermit-abi@0.3.2
  74. hex-literal@0.4.1
  75. home@0.5.5
  76. iana-time-zone@0.1.57
  77. iana-time-zone-haiku@0.1.2
  78. image@0.24.7
  79. indexmap@2.0.0
  80. indoc@2.0.3
  81. io-lifetimes@1.0.11
  82. itertools@0.11.0
  83. itoa@1.0.9
  84. jpeg-decoder@0.3.0
  85. js-sys@0.3.64
  86. lazy-bytes-cast@5.0.1
  87. lazy_static@1.4.0
  88. libc@0.2.147
  89. libgpg-error-sys@0.6.0
  90. libloading@0.8.0
  91. linux-raw-sys@0.3.8
  92. linux-raw-sys@0.4.7
  93. lock_api@0.4.10
  94. log@0.4.20
  95. malloc_buf@0.0.6
  96. memchr@2.6.3
  97. memmap2@0.5.10
  98. memoffset@0.6.5
  99. memoffset@0.7.1
  100. minimal-lexical@0.2.1
  101. miniz_oxide@0.7.1
  102. mio@0.8.8
  103. nix@0.24.3
  104. nom@7.1.3
  105. num-integer@0.1.45
  106. num-rational@0.4.1
  107. num-traits@0.2.16
  108. objc@0.2.7
  109. objc-foundation@0.1.1
  110. objc_id@0.1.1
  111. object@0.32.1
  112. once_cell@1.18.0
  113. option-ext@0.2.0
  114. parking_lot@0.12.1
  115. parking_lot_core@0.9.8
  116. paste@1.0.14
  117. pkg-config@0.3.27
  118. pretty_assertions@1.4.0
  119. proc-macro2@1.0.66
  120. quote@1.0.33
  121. ratatui@0.23.0
  122. redox_syscall@0.2.16
  123. redox_syscall@0.3.5
  124. redox_users@0.4.3
  125. rust-embed@8.0.0
  126. rust-embed-impl@8.0.0
  127. rust-embed-utils@8.0.0
  128. rustc-demangle@0.1.23
  129. rustix@0.37.23
  130. rustix@0.38.12
  131. rustversion@1.0.14
  132. ryu@1.0.15
  133. same-file@1.0.6
  134. scoped-tls@1.0.1
  135. scopeguard@1.2.0
  136. serde@1.0.188
  137. serde_derive@1.0.188
  138. serde_json@1.0.106
  139. serde_spanned@0.6.3
  140. sha2@0.10.7
  141. shellexpand@3.1.0
  142. signal-hook@0.3.17
  143. signal-hook-mio@0.2.3
  144. signal-hook-registry@1.4.1
  145. smallvec@1.11.0
  146. smithay-client-toolkit@0.16.0
  147. smithay-clipboard@0.6.6
  148. static_assertions@1.1.0
  149. strsim@0.10.0
  150. strum@0.25.0
  151. strum_macros@0.25.2
  152. syn@2.0.31
  153. system-deps@6.1.1
  154. target-lexicon@0.12.11
  155. terminal_size@0.2.6
  156. thiserror@1.0.48
  157. thiserror-impl@1.0.48
  158. tinytemplate@1.2.1
  159. toml@0.7.8
  160. toml_datetime@0.6.3
  161. toml_edit@0.19.15
  162. typenum@1.16.0
  163. unicode-ident@1.0.11
  164. unicode-segmentation@1.10.1
  165. unicode-width@0.1.10
  166. utf8parse@0.2.1
  167. version-compare@0.1.1
  168. version_check@0.9.4
  169. walkdir@2.4.0
  170. wasi@0.11.0+wasi-snapshot-preview1
  171. wasm-bindgen@0.2.87
  172. wasm-bindgen-backend@0.2.87
  173. wasm-bindgen-macro@0.2.87
  174. wasm-bindgen-macro-support@0.2.87
  175. wasm-bindgen-shared@0.2.87
  176. wayland-client@0.29.5
  177. wayland-commons@0.29.5
  178. wayland-cursor@0.29.5
  179. wayland-protocols@0.29.5
  180. wayland-scanner@0.29.5
  181. wayland-sys@0.29.5
  182. which@4.4.2
  183. winapi@0.3.9
  184. winapi-i686-pc-windows-gnu@0.4.0
  185. winapi-util@0.1.5
  186. winapi-wsapoll@0.1.1
  187. winapi-x86_64-pc-windows-gnu@0.4.0
  188. windows@0.48.0
  189. windows-sys@0.45.0
  190. windows-sys@0.48.0
  191. windows-targets@0.42.2
  192. windows-targets@0.48.5
  193. windows_aarch64_gnullvm@0.42.2
  194. windows_aarch64_gnullvm@0.48.5
  195. windows_aarch64_msvc@0.42.2
  196. windows_aarch64_msvc@0.48.5
  197. windows_i686_gnu@0.42.2
  198. windows_i686_gnu@0.48.5
  199. windows_i686_msvc@0.42.2
  200. windows_i686_msvc@0.48.5
  201. windows_x86_64_gnu@0.42.2
  202. windows_x86_64_gnu@0.48.5
  203. windows_x86_64_gnullvm@0.42.2
  204. windows_x86_64_gnullvm@0.48.5
  205. windows_x86_64_msvc@0.42.2
  206. windows_x86_64_msvc@0.48.5
  207. winnow@0.5.15
  208. winreg@0.10.1
  209. x11-clipboard@0.7.1
  210. x11rb@0.10.1
  211. x11rb-protocol@0.10.0
  212. xcursor@0.3.4
  213. xml-rs@0.8.18
  214. yansi@0.5.1
  215. ${PN}@${PV}
  216. "
  217. inherit bash-completion-r1 cargo
  218. DESCRIPTION="Terminal User Interface for GnuPG"
  219. HOMEPAGE="
  220. https://crates.io/crates/gpg-tui
  221. https://github.com/orhun/gpg-tui
  222. "
  223. SRC_URI="
  224. ${CARGO_CRATE_URIS}
  225. https://github.com/orhun/${PN}/raw/v${PV}/man/${PN}.1 -> ${P}.man.1
  226. https://github.com/orhun/${PN}/raw/v${PV}/man/${PN}.toml.5 -> ${P}.toml.man.5
  227. "
  228. LICENSE="MIT"
  229. # Dependent crate licenses
  230. LICENSE+="
  231. Apache-2.0 Apache-2.0-with-LLVM-exceptions Boost-1.0 ISC LGPL-2.1
  232. MIT MPL-2.0 Unicode-DFS-2016 Unlicense
  233. "
  234. SLOT="0"
  235. KEYWORDS="amd64 ~x86"
  236. RESTRICT="mirror"
  237. DEPEND="
  238. app-crypt/gpgme
  239. dev-libs/libgpg-error
  240. x11-libs/libxcb
  241. "
  242. RDEPEND="${DEPEND}"
  243. BDEPEND="x11-libs/libxkbcommon"
  244. src_unpack() {
  245. cargo_src_unpack
  246. local man="${T}/man"
  247. mkdir -- "${man}" || die
  248. cp -v -- "${DISTDIR}/${P}.man.1" "${man}/${PN}.1" || die
  249. cp -v -- "${DISTDIR}/${P}.toml.man.5" "${man}/${PN}.toml.5" || die
  250. }
  251. src_install() {
  252. cargo_src_install
  253. doman "${T}/man"/*
  254. local exe="${ED}/usr/bin/${PN}-completions"
  255. local completions="${S}/completions"
  256. mkdir -p "${completions}" || die
  257. ebegin "generating completions"
  258. OUT_DIR="${completions}" "${exe}"
  259. eend "${?}" 'failed to generate completions' || die "${_}"
  260. rm "${exe}" || die
  261. # bash-completion
  262. newbashcomp "completions/${PN}.bash" "${PN}"
  263. # zsh-completion
  264. insinto /usr/share/zsh/site-functions
  265. doins "completions/_${PN}"
  266. # fish-completion
  267. insinto /usr/share/fish/vendor_completions.d
  268. doins "completions/${PN}.fish"
  269. }