re2c.scm 2.0 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2017 Sergei Trofimovich <slyfox@inbox.ru>
  3. ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
  4. ;;;
  5. ;;; This file is part of GNU Guix.
  6. ;;;
  7. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  8. ;;; under the terms of the GNU General Public License as published by
  9. ;;; the Free Software Foundation; either version 3 of the License, or (at
  10. ;;; your option) any later version.
  11. ;;;
  12. ;;; GNU Guix is distributed in the hope that it will be useful, but
  13. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  14. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. ;;; GNU General Public License for more details.
  16. ;;;
  17. ;;; You should have received a copy of the GNU General Public License
  18. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  19. (define-module (gnu packages re2c)
  20. #:use-module (guix licenses)
  21. #:use-module (guix packages)
  22. #:use-module (guix download)
  23. #:use-module (guix build-system gnu))
  24. (define-public re2c
  25. (package
  26. (name "re2c")
  27. (version "1.1.1")
  28. (source (origin
  29. (method url-fetch)
  30. (uri (string-append "https://github.com/skvadrik/" name
  31. "/releases/download/" version "/"
  32. name "-" version ".tar.gz"))
  33. (sha256
  34. (base32
  35. "1ksifjn18v6nra935dpqllmvkqgcdsggfjgmj77282x0gqrrfrc5"))))
  36. (build-system gnu-build-system)
  37. (home-page "http://re2c.org/")
  38. (synopsis "Lexer generator for C/C++")
  39. (description
  40. "@code{re2c} generates minimalistic hard-coded state machine (as opposed
  41. to full-featured table-based lexers). Flexible API allows generated code
  42. to be wired into virtually any environment. Instead of exposing traditional
  43. @code{yylex()} style API, re2c exposes its internals. Be sure to take a look
  44. at examples, they cover a lot of real-world cases and shed some light on dark
  45. corners of re2c API.")
  46. (license public-domain)))