12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849 |
- ;;; GNU Guix --- Functional package management for GNU
- ;;; Copyright © 2017 Sergei Trofimovich <slyfox@inbox.ru>
- ;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
- ;;;
- ;;; This file is part of GNU Guix.
- ;;;
- ;;; GNU Guix is free software; you can redistribute it and/or modify it
- ;;; under the terms of the GNU General Public License as published by
- ;;; the Free Software Foundation; either version 3 of the License, or (at
- ;;; your option) any later version.
- ;;;
- ;;; GNU Guix is distributed in the hope that it will be useful, but
- ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
- ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- ;;; GNU General Public License for more details.
- ;;;
- ;;; You should have received a copy of the GNU General Public License
- ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
- (define-module (gnu packages re2c)
- #:use-module (guix licenses)
- #:use-module (guix packages)
- #:use-module (guix download)
- #:use-module (guix build-system gnu))
- (define-public re2c
- (package
- (name "re2c")
- (version "1.1.1")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/skvadrik/" name
- "/releases/download/" version "/"
- name "-" version ".tar.gz"))
- (sha256
- (base32
- "1ksifjn18v6nra935dpqllmvkqgcdsggfjgmj77282x0gqrrfrc5"))))
- (build-system gnu-build-system)
- (home-page "http://re2c.org/")
- (synopsis "Lexer generator for C/C++")
- (description
- "@code{re2c} generates minimalistic hard-coded state machine (as opposed
- to full-featured table-based lexers). Flexible API allows generated code
- to be wired into virtually any environment. Instead of exposing traditional
- @code{yylex()} style API, re2c exposes its internals. Be sure to take a look
- at examples, they cover a lot of real-world cases and shed some light on dark
- corners of re2c API.")
- (license public-domain)))
|