less.scm 1.8 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
  3. ;;;
  4. ;;; This file is part of GNU Guix.
  5. ;;;
  6. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  7. ;;; under the terms of the GNU General Public License as published by
  8. ;;; the Free Software Foundation; either version 3 of the License, or (at
  9. ;;; your option) any later version.
  10. ;;;
  11. ;;; GNU Guix is distributed in the hope that it will be useful, but
  12. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  13. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  14. ;;; GNU General Public License for more details.
  15. ;;;
  16. ;;; You should have received a copy of the GNU General Public License
  17. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  18. (define-module (gnu packages less)
  19. #:use-module (guix licenses)
  20. #:use-module (gnu packages ncurses)
  21. #:use-module (guix packages)
  22. #:use-module (guix download)
  23. #:use-module (guix build-system gnu))
  24. (define-public less
  25. (package
  26. (name "less")
  27. (version "530")
  28. (source
  29. (origin
  30. (method url-fetch)
  31. (uri (string-append "mirror://gnu/less/less-"
  32. version ".tar.gz"))
  33. (sha256
  34. (base32
  35. "1qpj2z38c53qmvqn8jaa0kq26q989cfbfjj4y0s6z17l1amr2gsh"))))
  36. (build-system gnu-build-system)
  37. (inputs `(("ncurses" ,ncurses)))
  38. (home-page "https://www.gnu.org/software/less/")
  39. (synopsis "Paginator for terminals")
  40. (description
  41. "GNU less is a pager, a program that allows you to view large amounts
  42. of text in page-sized chunks. Unlike traditional pagers, it allows both
  43. backwards and forwards movement through the document. It also does not have
  44. to read the entire input file before starting, so it starts faster than most
  45. text editors.")
  46. (license gpl3+))) ; some files are under GPLv2+