12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849 |
- ;;; GNU Guix --- Functional package management for GNU
- ;;; Copyright © 2012 Nikita Karetnikov <nikita@karetnikov.org>
- ;;;
- ;;; This file is part of GNU Guix.
- ;;;
- ;;; GNU Guix is free software; you can redistribute it and/or modify it
- ;;; under the terms of the GNU General Public License as published by
- ;;; the Free Software Foundation; either version 3 of the License, or (at
- ;;; your option) any later version.
- ;;;
- ;;; GNU Guix is distributed in the hope that it will be useful, but
- ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
- ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- ;;; GNU General Public License for more details.
- ;;;
- ;;; You should have received a copy of the GNU General Public License
- ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
- (define-module (gnu packages less)
- #:use-module (guix licenses)
- #:use-module (gnu packages ncurses)
- #:use-module (guix packages)
- #:use-module (guix download)
- #:use-module (guix build-system gnu))
- (define-public less
- (package
- (name "less")
- (version "530")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/less/less-"
- version ".tar.gz"))
- (sha256
- (base32
- "1qpj2z38c53qmvqn8jaa0kq26q989cfbfjj4y0s6z17l1amr2gsh"))))
- (build-system gnu-build-system)
- (inputs `(("ncurses" ,ncurses)))
- (home-page "https://www.gnu.org/software/less/")
- (synopsis "Paginator for terminals")
- (description
- "GNU less is a pager, a program that allows you to view large amounts
- of text in page-sized chunks. Unlike traditional pagers, it allows both
- backwards and forwards movement through the document. It also does not have
- to read the entire input file before starting, so it starts faster than most
- text editors.")
- (license gpl3+))) ; some files are under GPLv2+
|