base.nix 1.5 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283
  1. { lib, pkgs, ... }:
  2. with lib;
  3. let
  4. find = "${pkgs.fd}/bin/fd -calways -uE'.git' --strip-cwd-prefix";
  5. in {
  6. i18n.defaultLocale = mkDefault "ru_RU.UTF-8";
  7. time.timeZone = mkDefault "Asia/Novosibirsk";
  8. users.defaultUserShell = pkgs.zsh;
  9. hardware.enableRedistributableFirmware = mkDefault true;
  10. services = {
  11. fwupd.enable = mkDefault true;
  12. getty.helpLine = mkForce "";
  13. };
  14. systemd.tmpfiles.rules = [
  15. "w- /sys/kernel/mm/lru_gen/enabled - - - - y"
  16. "w- /sys/kernel/mm/lru_gen/min_ttl_ms - - - - 1000"
  17. ];
  18. environment = {
  19. localBinInPath = mkDefault true;
  20. pathsToLink = [ "/libexec" ];
  21. sessionVariables = {
  22. EDITOR = "vi";
  23. FZF_DEFAULT_COMMAND = find + " -tf";
  24. FZF_ALT_C_COMMAND = find + " -td";
  25. FZF_CTRL_T_COMMAND = find + " -tf";
  26. FZF_DEFAULT_OPTS = "--ansi";
  27. FZF_TMUX = "1";
  28. };
  29. systemPackages = with pkgs; [
  30. _7zz
  31. bfs
  32. binutils
  33. btrfs-progs
  34. byedpi
  35. cifs-utils
  36. compsize
  37. curl
  38. direnv
  39. dnsutils
  40. dua
  41. e2fsprogs
  42. efibootmgr
  43. exfatprogs
  44. fd
  45. file
  46. fzf
  47. git
  48. gptfdisk
  49. jq
  50. lsof
  51. ncdu
  52. nfs-utils
  53. nil
  54. nix-diff
  55. nix-direnv
  56. nmap
  57. nvd
  58. (hiPrio nvi)
  59. nvme-cli
  60. pciutils
  61. pinentry-curses
  62. (hiPrio procps)
  63. pwgen
  64. ripgrep
  65. rsync
  66. sbctl
  67. smartmontools
  68. squashfsTools
  69. translate-shell
  70. unrar
  71. unzip
  72. (hiPrio vim-with-vimrc)
  73. zip
  74. ];
  75. };
  76. }