base.nix 1.4 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879
  1. { lib, pkgs, ... }:
  2. with lib;
  3. let
  4. find = "${pkgs.fd}/bin/fd -calways -uE'.git' --strip-cwd-prefix";
  5. in {
  6. i18n.defaultLocale = mkDefault "ru_RU.UTF-8";
  7. time.timeZone = mkDefault "Asia/Novosibirsk";
  8. users.defaultUserShell = pkgs.zsh;
  9. services = {
  10. fwupd.enable = mkDefault true;
  11. getty.helpLine = mkForce "";
  12. };
  13. systemd.tmpfiles.rules = [
  14. "w- /sys/kernel/mm/lru_gen/enabled - - - - y"
  15. "w- /sys/kernel/mm/lru_gen/min_ttl_ms - - - - 1000"
  16. ];
  17. environment = {
  18. localBinInPath = mkDefault true;
  19. pathsToLink = [ "/libexec" ];
  20. sessionVariables = {
  21. EDITOR = "vi";
  22. FZF_DEFAULT_COMMAND = find + " -tf";
  23. FZF_ALT_C_COMMAND = find + " -td";
  24. FZF_CTRL_T_COMMAND = find + " -tf";
  25. FZF_DEFAULT_OPTS = "--ansi";
  26. FZF_TMUX = "1";
  27. };
  28. systemPackages = with pkgs; [
  29. _7zz
  30. bfs
  31. binutils
  32. btrfs-progs
  33. cifs-utils
  34. compsize
  35. curl
  36. direnv
  37. dnsutils
  38. dua
  39. e2fsprogs
  40. efibootmgr
  41. exfatprogs
  42. fd
  43. file
  44. fzf
  45. git
  46. gptfdisk
  47. jq
  48. lsof
  49. ncdu
  50. nfs-utils
  51. nil
  52. nix-diff
  53. nix-direnv
  54. nmap
  55. nvd
  56. (hiPrio nvi)
  57. nvme-cli
  58. pciutils
  59. pinentry-curses
  60. (hiPrio procps)
  61. pwgen
  62. ripgrep
  63. rsync
  64. smartmontools
  65. squashfsTools
  66. translate-shell
  67. unrar
  68. unzip
  69. (hiPrio vim-with-vimrc)
  70. zip
  71. ];
  72. };
  73. }