123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869 |
- # Do not modify this file! It was generated by ‘nixos-generate-config’
- # and may be overwritten by future invocations. Please make changes
- # to /etc/nixos/configuration.nix instead.
- { config, lib, modulesPath, ... }:
- {
- imports =
- [ (modulesPath + "/installer/scan/not-detected.nix")
- ];
- boot.initrd.availableKernelModules = [
- "ehci_pci" "ahci" "usb_storage" "sd_mod" "sr_mod" "rtsx_usb_sdmmc"
- "libchacha" "chacha_generic" "chacha_x86_64"
- "adiantum" "libpoly1305" "nhpoly1305" "nhpoly1305_sse2"
- ];
- boot.initrd.kernelModules = [ ];
- boot.kernelModules = [ ];
- boot.extraModulePackages = [ ];
- fileSystems."/" =
- { device = "none";
- fsType = "tmpfs";
- };
- fileSystems."/system" =
- { device = "/dev/disk/by-uuid/d8646471-3bfb-4e2a-ba23-5c3587911784";
- fsType = "btrfs";
- options = [ "subvol=/" ];
- };
- boot.initrd.luks.devices."nixos".device = "/dev/disk/by-uuid/2416383a-e744-4e4d-9dd3-52a039509064";
- fileSystems."/nix" =
- { device = "/dev/disk/by-uuid/d8646471-3bfb-4e2a-ba23-5c3587911784";
- fsType = "btrfs";
- options = [ "subvol=/nix" ];
- };
- fileSystems."/home" =
- { device = "/dev/disk/by-uuid/d8646471-3bfb-4e2a-ba23-5c3587911784";
- fsType = "btrfs";
- options = [ "subvol=/home" ];
- };
- fileSystems."/boot" =
- { device = "/dev/disk/by-uuid/C18B-7359";
- fsType = "vfat";
- };
- swapDevices = [
- { device = "/dev/disk/by-uuid/fb9b9f3e-41a8-405a-b8e2-6be7565df81d"; }
- ];
- boot.resumeDevice = (builtins.head config.swapDevices).device;
- boot.initrd.luks.devices."swap".device = "/dev/disk/by-uuid/a2ef7829-5879-48c0-b10b-669bf6818b47";
- # Enables DHCP on each ethernet and wireless interface. In case of scripted networking
- # (the default) this is the recommended approach. When using systemd-networkd it's
- # still possible to use this option, but it's recommended to use it in conjunction
- # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
- networking.useDHCP = lib.mkDefault true;
- # networking.interfaces.enp1s0.useDHCP = lib.mkDefault true;
- # networking.interfaces.wlp2s0b1.useDHCP = lib.mkDefault true;
- nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
- powerManagement.cpuFreqGovernor = lib.mkDefault "schedutil";
- hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
- }
|