hardware-configuration.nix 2.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869
  1. # Do not modify this file! It was generated by ‘nixos-generate-config’
  2. # and may be overwritten by future invocations. Please make changes
  3. # to /etc/nixos/configuration.nix instead.
  4. { config, lib, modulesPath, ... }:
  5. {
  6. imports =
  7. [ (modulesPath + "/installer/scan/not-detected.nix")
  8. ];
  9. boot.initrd.availableKernelModules = [
  10. "ehci_pci" "ahci" "usb_storage" "sd_mod" "sr_mod" "rtsx_usb_sdmmc"
  11. "libchacha" "chacha_generic" "chacha_x86_64"
  12. "adiantum" "libpoly1305" "nhpoly1305" "nhpoly1305_sse2"
  13. ];
  14. boot.initrd.kernelModules = [ ];
  15. boot.kernelModules = [ ];
  16. boot.extraModulePackages = [ ];
  17. fileSystems."/" =
  18. { device = "none";
  19. fsType = "tmpfs";
  20. };
  21. fileSystems."/system" =
  22. { device = "/dev/disk/by-uuid/d8646471-3bfb-4e2a-ba23-5c3587911784";
  23. fsType = "btrfs";
  24. options = [ "subvol=/" ];
  25. };
  26. boot.initrd.luks.devices."nixos".device = "/dev/disk/by-uuid/2416383a-e744-4e4d-9dd3-52a039509064";
  27. fileSystems."/nix" =
  28. { device = "/dev/disk/by-uuid/d8646471-3bfb-4e2a-ba23-5c3587911784";
  29. fsType = "btrfs";
  30. options = [ "subvol=/nix" ];
  31. };
  32. fileSystems."/home" =
  33. { device = "/dev/disk/by-uuid/d8646471-3bfb-4e2a-ba23-5c3587911784";
  34. fsType = "btrfs";
  35. options = [ "subvol=/home" ];
  36. };
  37. fileSystems."/boot" =
  38. { device = "/dev/disk/by-uuid/C18B-7359";
  39. fsType = "vfat";
  40. };
  41. swapDevices = [
  42. { device = "/dev/disk/by-uuid/fb9b9f3e-41a8-405a-b8e2-6be7565df81d"; }
  43. ];
  44. boot.resumeDevice = (builtins.head config.swapDevices).device;
  45. boot.initrd.luks.devices."swap".device = "/dev/disk/by-uuid/a2ef7829-5879-48c0-b10b-669bf6818b47";
  46. # Enables DHCP on each ethernet and wireless interface. In case of scripted networking
  47. # (the default) this is the recommended approach. When using systemd-networkd it's
  48. # still possible to use this option, but it's recommended to use it in conjunction
  49. # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
  50. networking.useDHCP = lib.mkDefault true;
  51. # networking.interfaces.enp1s0.useDHCP = lib.mkDefault true;
  52. # networking.interfaces.wlp2s0b1.useDHCP = lib.mkDefault true;
  53. nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
  54. powerManagement.cpuFreqGovernor = lib.mkDefault "schedutil";
  55. hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
  56. }