rules 686 B

123456789101112131415161718192021222324252627
  1. #!/usr/bin/make -f
  2. # See debhelper(7) (uncomment to enable)
  3. # output every command that modifies files on the build system.
  4. export DH_VERBOSE = 1
  5. # see EXAMPLES in dpkg-buildflags(1) and read /usr/share/dpkg/*
  6. DPKG_EXPORT_BUILDFLAGS = 1
  7. include /usr/share/dpkg/default.mk
  8. # see FEATURE AREAS in dpkg-buildflags(1)
  9. export DEB_BUILD_MAINT_OPTIONS = hardening=+all
  10. # configure script detects optimization and debbuging flags automatically
  11. export DEB_CFLAGS_MAINT_STRIP = -O2 -g
  12. # main packaging script based on dh7 syntax
  13. %:
  14. dh $@ --with autoreconf
  15. override_dh_autoreconf:
  16. dh_autoreconf ./bootstrap
  17. override_dh_auto_configure:
  18. dh_auto_configure -- --enable-mlucas-default-path