PKGBUILD 985 B

12345678910111213141516171819202122232425262728293031
  1. # Maintainer: Luke T. Shumaker <lukeshu@parabola.nu>
  2. # Maintainer (aur): Frederick Zhang <frederick888@tsundere.moe>
  3. # Maintainer (arch): Andrzej Giniewicz <gginiu@gmail.com>
  4. # Contributor (arch): Smith Dhumbumroong <zodmaner at gmail dot com>
  5. # Justification for inclusion in Parabola:
  6. # - The repo.parabola.nu server uses it.
  7. # - LukeShu wants it.
  8. pkgname=unionfs-fuse
  9. pkgver=3.5
  10. pkgrel=1
  11. pkgdesc="A user space unionfs implementation"
  12. arch=('x86_64' 'i686' 'armv7h')
  13. url="https://github.com/rpodgorny/unionfs-fuse"
  14. license=('BSD-3-Clause')
  15. depends=('fuse3')
  16. source=("$pkgname-$pkgver.tar.gz::https://github.com/rpodgorny/unionfs-fuse/archive/v${pkgver}.tar.gz")
  17. sha256sums=('d33bddea64d4974387a8c88292f5a8424bac5da1cf8b7f4f394c803305de73f3')
  18. build() {
  19. cd $pkgname-$pkgver
  20. make
  21. }
  22. package() {
  23. cd $pkgname-$pkgver
  24. make SBINDIR="/bin" DESTDIR="$pkgdir" PREFIX=/usr install
  25. install -Dm644 "$srcdir"/$pkgname-$pkgver/LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
  26. }