PKGBUILD 1.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Maintainer (arch): Brad Fanella <cesura@archlinux.org>
  2. # Contributor: Martin Wimpress <code@flexion.org>
  3. # Contributor: André Silva <emulatorman@hyperbola.info>
  4. # Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
  5. pkgname=mate-sensors-applet
  6. pkgver=1.24.0
  7. pkgrel=1
  8. pkgrel+=.parabola1
  9. pkgdesc="A MATE Panel applet to display readings from hardware sensors, including CPU temperature, fan speeds and voltage readings"
  10. pkgdesc+=", without nonfree libxnvctrl support"
  11. url="https://mate-desktop.org"
  12. arch=('x86_64')
  13. arch+=('i686' 'armv7h')
  14. license=('GPL')
  15. depends=('libatasmart' 'libnotify' 'lm_sensors' 'mate-panel' 'gettext')
  16. makedepends=('docbook-xsl' 'itstool')
  17. groups=('mate-extra')
  18. conflicts=('mate-sensors-applet-gtk3')
  19. replaces=('mate-sensors-applet-gtk3')
  20. source=("https://pub.mate-desktop.org/releases/${pkgver%.*}/${pkgname}-${pkgver}.tar.xz")
  21. sha256sums=('5a604dd7ede7f5889817d936486b83b720ad500f097154635623ad3ee47ff2c7')
  22. build() {
  23. cd "${pkgname}-${pkgver}"
  24. ./configure \
  25. --prefix=/usr \
  26. --libexecdir=/usr/lib/${pkgname}
  27. #https://bugzilla.gnome.org/show_bug.cgi?id=656231
  28. sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
  29. make
  30. }
  31. package() {
  32. cd "${pkgname}-${pkgver}"
  33. make DESTDIR="${pkgdir}" install
  34. }