PKGBUILD 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. # $Id$
  2. # Maintainer (arch): Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
  3. # Contributor: Andreas Grapentin <andreas@grapentin.org>
  4. # Contributor: Márcio Silva <coadde@hyperbola.info>
  5. # parabola changes and rationale:
  6. # - removed libgdata support
  7. pkgname=eog-plugins
  8. pkgver=3.26.1
  9. pkgrel=1.nonprism1
  10. pkgdesc="Plugins for Eye of Gnome, without libgdata support"
  11. arch=(x86_64 i686 armv7h)
  12. url="https://wiki.gnome.org/Apps/EyeOfGnome/Plugins"
  13. license=(GPL2)
  14. depends=(eog libchamplain python)
  15. makedepends=(intltool gobject-introspection git)
  16. _commit=b665684a604fd0ca6f27650ac77e5dbc93c29fa3 # tags/3.26.1^0
  17. source=("git+https://git.gnome.org/browse/eog-plugins#commit=$_commit")
  18. sha256sums=('SKIP')
  19. pkgver() {
  20. cd $pkgname
  21. git describe --tags | sed 's/-/+/g'
  22. }
  23. prepare() {
  24. cd $pkgname
  25. NOCONFIGURE=1 ./autogen.sh
  26. }
  27. build() {
  28. cd $pkgname
  29. ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
  30. sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
  31. make
  32. }
  33. package() {
  34. cd $pkgname
  35. make DESTDIR="$pkgdir" install
  36. }
  37. # vim:set ts=2 sw=2 et: