123456789101112131415161718192021222324252627282930313233343536373839404142434445 |
- # $Id$
- # Maintainer (arch): Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
- # Contributor: Andreas Grapentin <andreas@grapentin.org>
- # Contributor: Márcio Silva <coadde@hyperbola.info>
- # parabola changes and rationale:
- # - removed libgdata support
- pkgname=eog-plugins
- pkgver=3.26.1
- pkgrel=1.nonprism1
- pkgdesc="Plugins for Eye of Gnome, without libgdata support"
- arch=(x86_64 i686 armv7h)
- url="https://wiki.gnome.org/Apps/EyeOfGnome/Plugins"
- license=(GPL2)
- depends=(eog libchamplain python)
- makedepends=(intltool gobject-introspection git)
- _commit=b665684a604fd0ca6f27650ac77e5dbc93c29fa3 # tags/3.26.1^0
- source=("git+https://git.gnome.org/browse/eog-plugins#commit=$_commit")
- sha256sums=('SKIP')
- pkgver() {
- cd $pkgname
- git describe --tags | sed 's/-/+/g'
- }
- prepare() {
- cd $pkgname
- NOCONFIGURE=1 ./autogen.sh
- }
- build() {
- cd $pkgname
- ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var
- sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
- make
- }
- package() {
- cd $pkgname
- make DESTDIR="$pkgdir" install
- }
- # vim:set ts=2 sw=2 et:
|