1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950 |
- # Maintainer (arch): Antonio Rojas <arojas@archlinux.org>
- # Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
- # Contributor: Zuf <kontakt.zuf@gmail.com>
- # Contributor: Darwin Bautista <djclue917@gmail.com>
- # Contributor: Gustavo Alvarez <sl1pkn07@gmail.com>
- # parabola changes and rationale:
- # - arch package links to qt5-webengine
- # - no changes necessary - simply rebuild without qt5-webengine in the environment
- pkgname=kdenlive
- pkgver=20.12.3
- pkgrel=1
- pkgrel+=.parabola1
- pkgdesc="A non-linear video editor for Linux using the MLT video framework"
- arch=(armv7h i686 x86_64)
- url="https://www.kdenlive.org/"
- license=(GPL)
- groups=(kde-applications kde-multimedia)
- depends=(knewstuff knotifyconfig kfilemetadata purpose mlt rttr breeze-icons frei0r-plugins)
- makedepends=(extra-cmake-modules kdoctools v4l-utils)
- makedepends_i686=('kcodecs>=5.79.0' 'kconfig>=5.79.0') # in [testing]
- optdepends=('ffmpeg: for FFmpeg plugin'
- 'cdrtools: for creation of DVD ISO images'
- 'dvdauthor: for creation of DVD'
- 'dvgrab: for firewire capture'
- 'recordmydesktop: for screen capture'
- 'xine-ui: for DVD preview'
- 'vlc: for DVD preview'
- 'opencv: for motion tracking'
- 'plasma-desktop: theme configuration')
- source=("https://download.kde.org/stable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
- sha256sums=('8d9f94699befc59b0a410d99dcafd445f33126678c18d859df4fceb553a88586'
- 'SKIP')
- validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <aacid@kde.org>
- F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87 # Christoph Feck <cfeck@kde.org>
- D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
- build() {
- cmake -B build -S $pkgname-$pkgver \
- -DBUILD_TESTING=OFF
- cmake --build build
- }
- package() {
- DESTDIR="$pkgdir" cmake --install build
- }
|