PKGBUILD 1.9 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. # Maintainer (arch): Antonio Rojas <arojas@archlinux.org>
  2. # Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
  3. # Contributor: Zuf <kontakt.zuf@gmail.com>
  4. # Contributor: Darwin Bautista <djclue917@gmail.com>
  5. # Contributor: Gustavo Alvarez <sl1pkn07@gmail.com>
  6. # parabola changes and rationale:
  7. # - arch package links to qt5-webengine
  8. # - no changes necessary - simply rebuild without qt5-webengine in the environment
  9. pkgname=kdenlive
  10. pkgver=20.12.3
  11. pkgrel=1
  12. pkgrel+=.parabola1
  13. pkgdesc="A non-linear video editor for Linux using the MLT video framework"
  14. arch=(armv7h i686 x86_64)
  15. url="https://www.kdenlive.org/"
  16. license=(GPL)
  17. groups=(kde-applications kde-multimedia)
  18. depends=(knewstuff knotifyconfig kfilemetadata purpose mlt rttr breeze-icons frei0r-plugins)
  19. makedepends=(extra-cmake-modules kdoctools v4l-utils)
  20. makedepends_i686=('kcodecs>=5.79.0' 'kconfig>=5.79.0') # in [testing]
  21. optdepends=('ffmpeg: for FFmpeg plugin'
  22. 'cdrtools: for creation of DVD ISO images'
  23. 'dvdauthor: for creation of DVD'
  24. 'dvgrab: for firewire capture'
  25. 'recordmydesktop: for screen capture'
  26. 'xine-ui: for DVD preview'
  27. 'vlc: for DVD preview'
  28. 'opencv: for motion tracking'
  29. 'plasma-desktop: theme configuration')
  30. source=("https://download.kde.org/stable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
  31. sha256sums=('8d9f94699befc59b0a410d99dcafd445f33126678c18d859df4fceb553a88586'
  32. 'SKIP')
  33. validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <aacid@kde.org>
  34. F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87 # Christoph Feck <cfeck@kde.org>
  35. D81C0CB38EB725EF6691C385BB463350D6EF31EF) # Heiko Becker <heiko.becker@kde.org>
  36. build() {
  37. cmake -B build -S $pkgname-$pkgver \
  38. -DBUILD_TESTING=OFF
  39. cmake --build build
  40. }
  41. package() {
  42. DESTDIR="$pkgdir" cmake --install build
  43. }