12345678910111213141516171819202122232425262728293031323334 |
- # Maintainer: Luke Shumaker <lukeshu@parabola.nu>
- pkgname=jh
- pkgver=0.5.3
- pkgdesc="Java helpers for PKGBUILDs"
- url="https://git.parabola.nu/packages/jh.git/"
- license=('custom:WTFPL')
- pkgrel=1
- arch=(any)
- makedepends=('git')
- optdepends=(
- "maven: for configurable maven local repository location"
- "librelib: for human readable output from jh checksource"
- )
- source=("git+https://git.parabola.nu/packages/${pkgname}.git#tag=v${pkgver}")
- sha256sums=('SKIP')
- build() {
- cd "$srcdir/$pkgname"
- make
- }
- package() {
- depends=(xmlstarlet)
- cd "$srcdir/$pkgname"
- make install DESTDIR="$pkgdir"
- install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
- }
|