PKGBUILD 672 B

12345678910111213141516171819202122232425262728293031323334
  1. # Maintainer: Luke Shumaker <lukeshu@parabola.nu>
  2. pkgname=jh
  3. pkgver=0.5.3
  4. pkgdesc="Java helpers for PKGBUILDs"
  5. url="https://git.parabola.nu/packages/jh.git/"
  6. license=('custom:WTFPL')
  7. pkgrel=1
  8. arch=(any)
  9. makedepends=('git')
  10. optdepends=(
  11. "maven: for configurable maven local repository location"
  12. "librelib: for human readable output from jh checksource"
  13. )
  14. source=("git+https://git.parabola.nu/packages/${pkgname}.git#tag=v${pkgver}")
  15. sha256sums=('SKIP')
  16. build() {
  17. cd "$srcdir/$pkgname"
  18. make
  19. }
  20. package() {
  21. depends=(xmlstarlet)
  22. cd "$srcdir/$pkgname"
  23. make install DESTDIR="$pkgdir"
  24. install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
  25. }