PKGBUILD 2.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172
  1. # $Id: PKGBUILD 114755 2014-07-03 20:47:41Z heftig $
  2. # Maintainer (Arch): Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
  3. # Contributor (Arch): Allan McRae <allan@archlinux.org>
  4. # Contributor (Arch): dorphell <dorphell@archlinux.org>
  5. # Maintainer (Hyperbola): André Silva <emulatorman@hyperbola.info>
  6. # Maintainer: Omar Vega Ramos <ovruni@gnu.org.pe>
  7. _pkgbasename=sdl
  8. pkgname=lib32-$_pkgbasename
  9. pkgver=1.2.15
  10. pkgrel=7.parabola1
  11. pkgdesc="A library for portable low-level access to a video framebuffer, audio output, mouse, and keyboard (32-bit), without nonfree riva_mmio.h file"
  12. arch=('x86_64')
  13. url="http://www.libsdl.org"
  14. license=('LGPL')
  15. conflicts=('lib32-sdl-libre')
  16. replaces=('lib32-sdl-libre')
  17. depends=('lib32-libxext' 'lib32-libxrender' 'lib32-libx11' $_pkgbasename)
  18. makedepends=('lib32-alsa-lib' 'lib32-mesa' 'lib32-libpulse' 'lib32-glu' gcc-multilib)
  19. optdepends=('lib32-alsa-lib: ALSA audio driver'
  20. 'lib32-libpulse: PulseAudio audio driver')
  21. options=('staticlibs')
  22. source=(https://repo.parabola.nu/other/sdl-libre/SDL-libre-${pkgver}.tar.gz
  23. sdl-1.2.14-fix-mouse-clicking.patch
  24. sdl-1.2.14-disable-mmx.patch
  25. fix_joystick_misc_axes.diff
  26. libsdl-1.2.15-resizing.patch
  27. sdl_x11sym.patch
  28. X11_KeyToUnicode.patch
  29. libre.patch)
  30. md5sums=('6b9b5ac27428e1a3b96c50604f2b1c40'
  31. '04d8c179f125e04bcd4c9d60e013c2d7'
  32. 'e5c16b7611f62c7cb25f0534eff68852'
  33. '687586a108b597a2a6b73070c1d37e51'
  34. '3dd50347d8856160a9cbd7f80383a1f8'
  35. '148b285bccee9d21bb96db807363b962'
  36. 'edea272dff4698470877c016d818918d'
  37. '71fb007f43825950d0ec7558a30253e0')
  38. prepare() {
  39. cd SDL-$pkgver
  40. patch -Np1 -i ../sdl-1.2.14-fix-mouse-clicking.patch
  41. patch -Np1 -i ../sdl-1.2.14-disable-mmx.patch
  42. patch -Np1 -i ../fix_joystick_misc_axes.diff
  43. patch -Np1 -i ../libsdl-1.2.15-resizing.patch
  44. patch -Np0 -i ../sdl_x11sym.patch
  45. patch -Np1 -i ../X11_KeyToUnicode.patch
  46. patch -Np1 -i ../libre.patch
  47. }
  48. build() {
  49. export CC="gcc -m32"
  50. export CXX="g++ -m32"
  51. export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
  52. cd SDL-$pkgver
  53. ./configure --prefix=/usr --disable-nasm --enable-alsa \
  54. --with-x --disable-rpath --disable-static --libdir=/usr/lib32
  55. make
  56. }
  57. package() {
  58. cd SDL-$pkgver
  59. make DESTDIR="$pkgdir" install
  60. rm -rf "$pkgdir"/usr/{include,share}
  61. cd "$pkgdir/usr/bin"
  62. mv sdl-config sdl-config-32
  63. }