12345678910111213141516171819202122232425262728293031323334353637 |
- # Committer(Arch): Judd Vinet <jvinet@zeroflux.org>
- # Maintainer: Parabola Hackers <dev@lists.parabola.nu>
- #
- # On armv7h the dosfstools is been missing from the official Parabola
- # repository for months. Since it was supposed to be fixed fast and it
- # has not been it's better to at least have something to not prevent
- # people from (re)installing parabola or installing packages that
- # depend on dosfstools.
- pkgname=dosfstools
- pkgver=4.2
- pkgrel=2
- pkgdesc="DOS filesystem utilities"
- arch=('armv7h')
- depends=('glibc')
- source=(https://github.com/$pkgname/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz{,.sig}
- )
- url="https://github.com/dosfstools/dosfstools"
- license=('GPL3')
- validpgpkeys=('25714AECDBFDACEE1CE95FE77F6022516E869F64') # Andreas Bombe
- md5sums=('49c8e457327dc61efab5b115a27b087a'
- 'SKIP')
- build() {
- cd $pkgname-$pkgver
- ./configure --prefix=/usr --libexecdir=/usr/lib \
- --sbindir=/usr/bin --mandir=/usr/share/man \
- --docdir=/usr/share/doc/dosfstools --enable-compat-symlinks
- make
- }
- package () {
- cd $pkgname-$pkgver
- make DESTDIR="$pkgdir" install
- }
|