PKGBUILD 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637
  1. # Committer(Arch): Judd Vinet <jvinet@zeroflux.org>
  2. # Maintainer: Parabola Hackers <dev@lists.parabola.nu>
  3. #
  4. # On armv7h the dosfstools is been missing from the official Parabola
  5. # repository for months. Since it was supposed to be fixed fast and it
  6. # has not been it's better to at least have something to not prevent
  7. # people from (re)installing parabola or installing packages that
  8. # depend on dosfstools.
  9. pkgname=dosfstools
  10. pkgver=4.2
  11. pkgrel=2
  12. pkgdesc="DOS filesystem utilities"
  13. arch=('armv7h')
  14. depends=('glibc')
  15. source=(https://github.com/$pkgname/$pkgname/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz{,.sig}
  16. )
  17. url="https://github.com/dosfstools/dosfstools"
  18. license=('GPL3')
  19. validpgpkeys=('25714AECDBFDACEE1CE95FE77F6022516E869F64') # Andreas Bombe
  20. md5sums=('49c8e457327dc61efab5b115a27b087a'
  21. 'SKIP')
  22. build() {
  23. cd $pkgname-$pkgver
  24. ./configure --prefix=/usr --libexecdir=/usr/lib \
  25. --sbindir=/usr/bin --mandir=/usr/share/man \
  26. --docdir=/usr/share/doc/dosfstools --enable-compat-symlinks
  27. make
  28. }
  29. package () {
  30. cd $pkgname-$pkgver
  31. make DESTDIR="$pkgdir" install
  32. }