PKGBUILD 1.0 KB

1234567891011121314151617181920212223242526272829303132
  1. # SPDX-License-Identifier: CC0-1.0
  2. # Maintainer: Parabola Hackers <dev@lists.parabola.nu>
  3. pkgname=your-init-freedom
  4. pkgver=20220719
  5. pkgrel=1
  6. _gitver=daf9eebc77cc719c818165e256efd5e0d5dee7aa
  7. pkgdesc="This package conflicts with every package known to work only for/with systemd."
  8. arch=(any)
  9. url=https://wiki.parabola.nu/Blacklist
  10. license=(GPL3)
  11. provides=(your-initfreedom)
  12. replaces=(your-initfreedom)
  13. makedepends=(librelib)
  14. install=${pkgname}.install
  15. source=(${pkgname}-blacklist-${_gitver}.txt::https://git.parabola.nu/blacklist.git/plain/${pkgname}-blacklist.txt?id=${_gitver})
  16. sha512sums=('0060ebc516b1aee1149186e53a1c665d6790da2db7e43ade136731c8b5bd7ab24c4ce9431af8c5a06f3ad569ab73bcd2e5ff0179ac3c8f332ae78fdc266addeb')
  17. package()
  18. {
  19. # collect blacklisted package names as pacman conflicts
  20. conflicts=( $( libreblacklist normalize < blacklist-${_gitver}.txt | \
  21. cut -d: -f1,2 | sed -n 's/:$//p' | sort -u ) )
  22. install -Dm644 ${pkgname}-blacklist-${_gitver}.txt "${pkgdir}"/usr/share/doc/${pkgname}/blacklist.txt
  23. }