1234567891011121314151617181920212223242526272829303132 |
- # SPDX-License-Identifier: CC0-1.0
- # Maintainer: Parabola Hackers <dev@lists.parabola.nu>
- pkgname=your-init-freedom
- pkgver=20220719
- pkgrel=1
- _gitver=daf9eebc77cc719c818165e256efd5e0d5dee7aa
- pkgdesc="This package conflicts with every package known to work only for/with systemd."
- arch=(any)
- url=https://wiki.parabola.nu/Blacklist
- license=(GPL3)
- provides=(your-initfreedom)
- replaces=(your-initfreedom)
- makedepends=(librelib)
- install=${pkgname}.install
- source=(${pkgname}-blacklist-${_gitver}.txt::https://git.parabola.nu/blacklist.git/plain/${pkgname}-blacklist.txt?id=${_gitver})
- sha512sums=('0060ebc516b1aee1149186e53a1c665d6790da2db7e43ade136731c8b5bd7ab24c4ce9431af8c5a06f3ad569ab73bcd2e5ff0179ac3c8f332ae78fdc266addeb')
- package()
- {
- # collect blacklisted package names as pacman conflicts
- conflicts=( $( libreblacklist normalize < blacklist-${_gitver}.txt | \
- cut -d: -f1,2 | sed -n 's/:$//p' | sort -u ) )
- install -Dm644 ${pkgname}-blacklist-${_gitver}.txt "${pkgdir}"/usr/share/doc/${pkgname}/blacklist.txt
- }
|