PKGBUILD 1.2 KB

1234567891011121314151617181920212223242526272829303132
  1. # $Id: PKGBUILD 107291 2014-03-16 16:05:59Z lfleischer $
  2. # Maintainer: Luke R. <g4jc@openmailbox.org> GPG: rsa4096/3EAE8697
  3. # Maintainer (arch): Lukas Fleischer <archlinux at cryptocrack dot de>
  4. # Contributor: Laurent Carlier <lordheavym@gmail.com>
  5. # Contributor: DsTr <dstr@gmail.com>
  6. # Contributor: Allan McRae <allan@archlinux.org>
  7. # Contibutor: André Silva <emulatorman@hyperbola.info>
  8. # Contributor: Freemor <freemor@freemor.ca>
  9. _pkgname=winetricks
  10. pkgname=winetricks-libre
  11. pkgver=1.1
  12. pkgrel=2
  13. pkgdesc='Script to install various redistributable runtime libraries in Wine (a libre fork of winetricks)'
  14. url='https://github.com/g4jc/winetricks-libre'
  15. license=('LGPL')
  16. arch=('any')
  17. replaces=($_pkgname)
  18. conflicts=($_pkgname)
  19. provides=($_pkgname)
  20. optdepends=('zenity: GUI for GNOME desktop'
  21. 'kdialog: GUI for KDE desktop')
  22. source=("https://github.com/g4jc/${pkgname}/archive/${pkgver}.tar.gz")
  23. sha512sums=('536db622cb853916f043323c7c7fb9bf7e56e942994260349fbd7c8b1e0122f9f851728302e2eab3fa60d5e909612cf3771895ca0d19062e9d8090ee9f6cdb6b')
  24. package() {
  25. depends=('wine' 'cabextract' 'unzip' 'xorg-xmessage')
  26. install -Dm755 "${srcdir}/${pkgname}-${pkgver}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
  27. ln -sv ${pkgname} "${pkgdir}/usr/bin/${_pkgname}"
  28. }