PKGBUILD 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. # Mainainer: Sébastien "Seblu" Luttringer <seblu@archlinux.org>
  2. # Contributor: Allan McRae <allan@archlinux.org>
  3. # Contributor: judd <jvinet@zeroflux.org>
  4. pkgname=gzip
  5. pkgver=1.9
  6. pkgrel=1
  7. pkgdesc='GNU compression utility'
  8. arch=(x86_64 ppc64le)
  9. url='https://www.gnu.org/software/gzip/'
  10. license=('GPL3')
  11. groups=('base' 'base-devel')
  12. depends=('glibc' 'bash' 'less')
  13. validpgpkeys=('155D3FC500C834486D1EEA677FD9FCCB000BEEEE') # Jim Meyering
  14. source=("https://ftp.gnu.org/pub/gnu/gzip/gzip-$pkgver.tar.xz"{,.sig})
  15. md5sums=('9492c6ccb2239ff679a5475a7bb543ed'
  16. 'SKIP')
  17. prepare() {
  18. cd $pkgname-$pkgver
  19. # apply patch from the source array (should be a pacman feature)
  20. local filename
  21. for filename in "${source[@]}"; do
  22. if [[ "$filename" =~ \.patch$ ]]; then
  23. msg2 "Applying patch ${filename##*/}"
  24. patch -p1 -N -i "$srcdir/${filename##*/}"
  25. fi
  26. done
  27. :
  28. }
  29. build() {
  30. cd $pkgname-$pkgver
  31. ./configure --prefix=/usr
  32. make
  33. }
  34. check() {
  35. cd $pkgname-$pkgver
  36. make check
  37. }
  38. package() {
  39. cd $pkgname-$pkgver
  40. make prefix="$pkgdir/usr" install
  41. }
  42. # vim:set ts=2 sw=2 et: