123456789101112131415161718192021222324252627282930313233343536373839404142434445464748 |
- # Mainainer: Sébastien "Seblu" Luttringer <seblu@archlinux.org>
- # Contributor: Allan McRae <allan@archlinux.org>
- # Contributor: judd <jvinet@zeroflux.org>
- pkgname=gzip
- pkgver=1.9
- pkgrel=1
- pkgdesc='GNU compression utility'
- arch=(x86_64 ppc64le)
- url='https://www.gnu.org/software/gzip/'
- license=('GPL3')
- groups=('base' 'base-devel')
- depends=('glibc' 'bash' 'less')
- validpgpkeys=('155D3FC500C834486D1EEA677FD9FCCB000BEEEE') # Jim Meyering
- source=("https://ftp.gnu.org/pub/gnu/gzip/gzip-$pkgver.tar.xz"{,.sig})
- md5sums=('9492c6ccb2239ff679a5475a7bb543ed'
- 'SKIP')
- prepare() {
- cd $pkgname-$pkgver
- # apply patch from the source array (should be a pacman feature)
- local filename
- for filename in "${source[@]}"; do
- if [[ "$filename" =~ \.patch$ ]]; then
- msg2 "Applying patch ${filename##*/}"
- patch -p1 -N -i "$srcdir/${filename##*/}"
- fi
- done
- :
- }
- build() {
- cd $pkgname-$pkgver
- ./configure --prefix=/usr
- make
- }
- check() {
- cd $pkgname-$pkgver
- make check
- }
- package() {
- cd $pkgname-$pkgver
- make prefix="$pkgdir/usr" install
- }
- # vim:set ts=2 sw=2 et:
|