Luacheck specifications for Roblox Lua

Austin Reuschle c98bc0ac0f Delete build.yml 1 year ago
img 891a6a3ab0 Update README.md 2 years ago
src ecada70521 Update to version-e3a7a4e5017e4419 and remove unused arguments 2 years ago
.gitignore f136c58c30 Baseline generation 2 years ago
LICENSE.md 5679ac5994 Add license 2 years ago
README.md ddbdc071a0 Merge branch 'master' of github.com:Quenty/luacheck-roblox 2 years ago
luacheck-roblox.sublime-project bb0f7fbd53 Add project 2 years ago
roblox_standard.lua ecada70521 Update to version-e3a7a4e5017e4419 and remove unused arguments 2 years ago

README.md

Roblox Luacheck

Generates the roblox_standard.lua file necessary to provide support for Roblox Lua in Luacheck.

What is Luacheck

If you're using Roblox outside of Roblox Studio, Luacheck is a linter that will analyze your code for you.

Examples

Here are some examples of the .luacheck in action. Traditional .luacheckrc files will not catch these errors.

Checking enums Checking script

Features

  • Automatically applies script and workspace properties
  • Automatically applies the Enum namespace
  • Has definitions for Roblox types and variables
  • Specifically ignores adding Workspace and other global variables following Roblox's standards
  • Does not show deprecated properties

Run and updating

To run you need Lua (5.1 or higher). Running the script will pull the latest version of the Roblox API and then pull in the latest Enums and game/workspace properties.

Usage

You can copy the contents of roblox_standard.lua into your .luacheckrc

Inspired by luacheck-love.