kde-systemtools.scm 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2017, 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
  3. ;;; Copyright © 2021 Tobias Geerinckx-Rice <me@tobias.gr>
  4. ;;; Copyright © 2021 Brendan Tildesley <mail@brendan.scot>
  5. ;;;
  6. ;;; This file is part of GNU Guix.
  7. ;;;
  8. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  9. ;;; under the terms of the GNU General Public License as published by
  10. ;;; the Free Software Foundation; either version 3 of the License, or (at
  11. ;;; your option) any later version.
  12. ;;;
  13. ;;; GNU Guix is distributed in the hope that it will be useful, but
  14. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  15. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  16. ;;; GNU General Public License for more details.
  17. ;;;
  18. ;;; You should have received a copy of the GNU General Public License
  19. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  20. (define-module (gnu packages kde-systemtools)
  21. #:use-module (guix build-system qt)
  22. #:use-module (guix download)
  23. #:use-module ((guix licenses) #:prefix license:)
  24. #:use-module (guix packages)
  25. #:use-module (guix utils)
  26. #:use-module (gnu packages)
  27. #:use-module (gnu packages compression)
  28. #:use-module (gnu packages kde)
  29. #:use-module (gnu packages kde-frameworks)
  30. #:use-module (gnu packages linux)
  31. #:use-module (gnu packages pkg-config)
  32. #:use-module (gnu packages qt)
  33. #:use-module (gnu packages ruby)
  34. #:use-module (gnu packages search)
  35. #:use-module (gnu packages vnc)
  36. #:use-module (gnu packages xml)
  37. #:use-module (gnu packages xorg))
  38. (define-public dolphin
  39. (package
  40. (name "dolphin")
  41. (version "21.08.1")
  42. (source
  43. (origin
  44. (method url-fetch)
  45. (uri (string-append "mirror://kde/stable/release-service/" version
  46. "/src/dolphin-" version ".tar.xz"))
  47. (sha256
  48. (base32 "1vmk9iaylw427x203ccdjhlbah3dr5fz7l3lc113nczq54kcwpbf"))))
  49. (build-system qt-build-system)
  50. (native-inputs
  51. `(("extra-cmake-modules" ,extra-cmake-modules)
  52. ("kdoctools" ,kdoctools)
  53. ("ruby" ,ruby)
  54. ("ruby-test-unit" ,ruby-test-unit)))
  55. (inputs
  56. `(("baloo" ,baloo)
  57. ("baloo-widgets" ,baloo-widgets)
  58. ("breeze-icons" ,breeze-icons)
  59. ("kactivities" ,kactivities)
  60. ("kbookmarks" ,kbookmarks)
  61. ("kcmutils" ,kcmutils)
  62. ("kcompletion" ,kcompletion)
  63. ("kconfig" ,kconfig)
  64. ("kcoreaddons" ,kcoreaddons)
  65. ("kcrash" ,kcrash)
  66. ("kdbusaddons" ,kdbusaddons)
  67. ("ki18n" ,ki18n)
  68. ("kiconthemes" ,kiconthemes)
  69. ("kinit" ,kinit)
  70. ("kio" ,kio)
  71. ("knewstuff" ,knewstuff)
  72. ("knotifications" ,knotifications)
  73. ("kparts" ,kparts)
  74. ("ktextwidgets" ,ktextwidgets)
  75. ("kwindowsystem" ,kwindowsystem)
  76. ("phonon" ,phonon)
  77. ("qtbase" ,qtbase-5)
  78. ("solid" ,solid)))
  79. (arguments
  80. `(#:tests? #f)) ;; TODO: 4/15 tests fail even with offscreen
  81. (home-page "https://apps.kde.org/dolphin/")
  82. (synopsis "File manager for KDE")
  83. (description "Dolphin is a file manager for KDE focusing on usability.
  84. The main features of Dolphin are:
  85. @itemize
  86. @item Navigation bar for URLs, which navigates quickly
  87. through the file hierarchy.
  88. @item View properties are remembered for each folder.
  89. @item Split of views is supported.
  90. @item Network transparency.
  91. @item Undo/redo functionality.
  92. @item Renaming of a variable number of selected items in one step.
  93. @end itemize")
  94. (license ;; GPL for programs, FDL for documentation
  95. (list license:gpl2+ license:fdl1.2+))))
  96. (define-public dolphin-plugins
  97. (package
  98. (name "dolphin-plugins")
  99. (version "21.08.1")
  100. (source
  101. (origin
  102. (method url-fetch)
  103. (uri (string-append "mirror://kde/stable/release-service/" version
  104. "/src/dolphin-plugins-" version ".tar.xz"))
  105. (sha256
  106. (base32 "0gnmr73ly0djngp3imdi4zm72icj3gilqcshb4ks3rq3lwk408rr"))))
  107. (build-system qt-build-system)
  108. (native-inputs
  109. `(("extra-cmake-modules" ,extra-cmake-modules)))
  110. (inputs
  111. `(("dolphin" ,dolphin)
  112. ("ki18n" ,ki18n)
  113. ("kio" ,kio)
  114. ("ksyntaxhighlighting" ,ksyntaxhighlighting)
  115. ("ktexteditor" ,ktexteditor)
  116. ("kxmlgui" ,kxmlgui)
  117. ("breeze-icons" ,breeze-icons) ;; default icon set
  118. ("qtbase" ,qtbase-5)))
  119. (home-page "http://www.kde.org/")
  120. (synopsis "VCS-Plugins for Dolphin")
  121. (description "This package contains plugins that offer integration in
  122. Dolphin with the version control systems: Bzr, Git, Mercurial, Subversion.")
  123. (license license:gpl2+)))
  124. (define-public khelpcenter
  125. (package
  126. (name "khelpcenter")
  127. (version "21.08.1")
  128. (source
  129. (origin
  130. (method url-fetch)
  131. (uri (string-append "mirror://kde/stable/release-service/" version
  132. "/src/khelpcenter-" version ".tar.xz"))
  133. (sha256
  134. (base32 "09ayg8kb4b4v30xjm8ca5csw1axipn1336mq2sfqra5qwkj8d93y"))))
  135. (build-system qt-build-system)
  136. (native-inputs
  137. `(("extra-cmake-modules" ,extra-cmake-modules)
  138. ("kdoctools" ,kdoctools)))
  139. (inputs
  140. `(("grantlee" ,grantlee)
  141. ("karchive" ,karchive)
  142. ("kbookmarks" ,kbookmarks)
  143. ("kcodecs" ,kcodecs)
  144. ("kconfig" ,kconfig)
  145. ("kcoreaddons" ,kcoreaddons)
  146. ("kdbusaddons" ,kdbusaddons)
  147. ("khtml" ,khtml)
  148. ("ki18n" ,ki18n)
  149. ("kinit" ,kinit)
  150. ("kio" ,kio)
  151. ("kjs" ,kjs)
  152. ("kparts" ,kparts)
  153. ("kservice" ,kservice)
  154. ("kwindowsystem" ,kwindowsystem)
  155. ("libxml2" ,libxml2)
  156. ("breeze-icons" ,breeze-icons) ;; default icon set
  157. ("qtbase" ,qtbase-5)
  158. ("xapian" ,xapian)))
  159. (arguments
  160. `(#:tests? #f)) ;; 1/1 test fails
  161. (home-page "https://apps.kde.org/help/")
  162. (synopsis "KDE documentation viewer")
  163. (description "KHelpCenter uses meta data files which describe the
  164. documentation available in the system. Each document is represented by a meta
  165. data file and shown as an entry in the KHelpCenter navigation tree view. The
  166. meta data contains information about title and short description of the
  167. document, the location of the document and some more information like how to
  168. search the document and translations of title and description. Document
  169. hierarchy is represented as hierarchy of the meta data files. Directories are
  170. also described by a meta data file which contains the same information as a
  171. document meta data file.")
  172. (license license:gpl2+)))
  173. (define-public konsole
  174. (package
  175. (name "konsole")
  176. (version "21.08.1")
  177. (source
  178. (origin
  179. (method url-fetch)
  180. (uri (string-append "mirror://kde/stable/release-service/" version
  181. "/src/konsole-" version ".tar.xz"))
  182. (sha256
  183. (base32 "0v74yrblwakbmy0p4x5j9lhmqyavgsffahr51bh5r5qcgx0cafjv"))))
  184. (build-system qt-build-system)
  185. (native-inputs
  186. `(("extra-cmake-modules" ,extra-cmake-modules)
  187. ("kdoctools" ,kdoctools)))
  188. (inputs
  189. `(("kbookmarks" ,kbookmarks)
  190. ("kcompletion" ,kcompletion)
  191. ("kconfig" ,kconfig)
  192. ("kconfigwidgets" ,kconfigwidgets)
  193. ("kcoreaddons" ,kcoreaddons)
  194. ("kcrash" ,kcrash)
  195. ("kdbusaddons" ,kdbusaddons)
  196. ("kguiaddons" ,kguiaddons)
  197. ("ki18n" ,ki18n)
  198. ("kiconthemes" ,kiconthemes)
  199. ("kinit" ,kinit)
  200. ("kio" ,kio)
  201. ("knewstuff" ,knewstuff)
  202. ("kglobalaccel" ,kglobalaccel)
  203. ("knotifications" ,knotifications)
  204. ("knotifyconfig" ,knotifyconfig)
  205. ("kparts" ,kparts)
  206. ("kpty" ,kpty)
  207. ("kservice" ,kservice)
  208. ("ktextwidgets" ,ktextwidgets)
  209. ("kwidgetsaddons" ,kwidgetsaddons)
  210. ("kwindowsystem" ,kwindowsystem)
  211. ("kxmlgui" ,kxmlgui)
  212. ("breeze-icons" ,breeze-icons) ;; default icon set
  213. ("qtbase" ,qtbase-5)
  214. ("qtscript" ,qtscript)))
  215. (arguments
  216. `(#:tests? #f)) ;; TODO: 2/15 tests fail even with HOME, offscreen, SHELL, debus
  217. (home-page "http://www.kde.org/")
  218. (synopsis "Terminal emulator similar for KDE")
  219. (description "Konsole is a terminal emulator, similar to xterm, built on
  220. the KDE Platform. It can contain multiple terminal sessions inside one window
  221. using detachable tabs. Konsole supports customizable schemes, saved sessions,
  222. output monitoring and more.
  223. This package is part of the KDE base applications module.")
  224. (license ;; GPL for programs, LGPL for libraries, FDL for documentation
  225. (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
  226. (define-public krfb
  227. (package
  228. (name "krfb")
  229. (version "21.08.1")
  230. (source
  231. (origin
  232. (method url-fetch)
  233. (uri (string-append "mirror://kde/stable/release-service/" version
  234. "/src/krfb-" version ".tar.xz"))
  235. (sha256
  236. (base32 "0l28l9wmfxf6vihxr86pwxj027fkz0k0pwkif8had0s4swc9jfnx"))))
  237. (build-system qt-build-system)
  238. (native-inputs
  239. `(("extra-cmake-modules" ,extra-cmake-modules)
  240. ("pkg-config" ,pkg-config)
  241. ("kdoctools" ,kdoctools)))
  242. (inputs
  243. `(("kcompletion" ,kcompletion)
  244. ("kconfig" ,kconfig)
  245. ("kcoreaddons" ,kcoreaddons)
  246. ("kcrash" ,kcrash)
  247. ("kdbusaddons" ,kdbusaddons)
  248. ("kdnssd" ,kdnssd)
  249. ("ki18n" ,ki18n)
  250. ("knotifications" ,knotifications)
  251. ("kwallet" ,kwallet)
  252. ("kwidgetsaddons" ,kwidgetsaddons)
  253. ("kwindowsystem" ,kwindowsystem)
  254. ("kxmlgui" ,kxmlgui)
  255. ("libvnc" ,libvnc)
  256. ("libxcb" ,libxcb)
  257. ("libxtst" ,libxtst)
  258. ("breeze-icons" ,breeze-icons) ;; default icon set
  259. ("pipewire" ,pipewire)
  260. ("qtbase" ,qtbase-5)
  261. ("qtx11extras" ,qtx11extras)
  262. ("xcb-util-image" ,xcb-util-image)
  263. ("zlib" ,zlib)))
  264. (home-page "https://apps.kde.org/krfb/")
  265. (synopsis "Desktop Sharing utility")
  266. (description "KDE Desktop Sharing is a server application that allows you
  267. to share your current session with a user on another machine. The desktop
  268. session can be viewed or even controlled remotely by any VNC or RFB client,
  269. such as the KDE Remote Desktop Connection client.
  270. KDE Desktop Sharing can restrict access to only users who are explicitly
  271. invited, and will ask for confirmation when a user attempts to connect.
  272. This package is part of the KDE networking module.")
  273. (license ;; GPL for programs, LGPL for libraries, FDL for documentation
  274. (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
  275. (define-public ksystemlog
  276. (package
  277. (name "ksystemlog")
  278. (version "21.08.1")
  279. (source
  280. (origin
  281. (method url-fetch)
  282. (uri (string-append "mirror://kde/stable/release-service/" version
  283. "/src/ksystemlog-" version ".tar.xz"))
  284. (sha256
  285. (base32 "1vv0wbb3npbq8r0mq8y5lc36qx1hxdjxygfcnw2h9hm4dwl8mc5v"))))
  286. (build-system qt-build-system)
  287. (native-inputs
  288. `(("extra-cmake-modules" ,extra-cmake-modules)
  289. ("kdoctools" ,kdoctools)))
  290. (inputs
  291. ;; Not including Journald since this is not used in guix
  292. `(("karchive" ,karchive)
  293. ("kcompletion" ,kcompletion)
  294. ("kconfig" ,kconfig)
  295. ("kcoreaddons" ,kcoreaddons)
  296. ("ki18n" ,ki18n)
  297. ("kiconthemes" ,kiconthemes)
  298. ("kio" ,kio)
  299. ("kitemviews" ,kitemviews)
  300. ("ktextwidgets" ,ktextwidgets)
  301. ("kwidgetsaddons" ,kwidgetsaddons)
  302. ("kxmlgui" ,kxmlgui)
  303. ("breeze-icons" ,breeze-icons) ;; default icon set
  304. ("qtbase" ,qtbase-5)))
  305. (home-page "https://apps.kde.org/ksystemlog/")
  306. (synopsis "System log viewer")
  307. (description "This program is developed for being used by beginner users,
  308. which don't know how to find information about their Linux system, and how the
  309. log files are in their computer. But it is also designed for advanced users,
  310. who want to quickly see problems occurring on their server.
  311. This package is part of the KDE administration module.")
  312. (license license:gpl2+)))
  313. (define-public yakuake
  314. (package
  315. (name "yakuake")
  316. (version "21.08.1")
  317. (source (origin
  318. (method url-fetch)
  319. (uri (string-append "mirror://kde/stable/release-service/" version
  320. "/src/yakuake-" version ".tar.xz"))
  321. (sha256
  322. (base32
  323. "1x41jrkvlff8x5qcd12lcrv6zqzw7jqw02ikpmqv1v4gw7lz94w9"))))
  324. (build-system qt-build-system)
  325. (native-inputs
  326. `(("extra-cmake-modules" ,extra-cmake-modules)))
  327. (inputs
  328. `(("breeze-icons" ,breeze-icons)
  329. ("karchive" ,karchive)
  330. ("kconfig" ,kconfig)
  331. ("kcoreaddons" ,kcoreaddons)
  332. ("kcrash" ,kcrash)
  333. ("kdbusaddons" ,kdbusaddons)
  334. ("kglobalaccel" ,kglobalaccel)
  335. ("ki18n" ,ki18n)
  336. ("kiconthemes" ,kiconthemes)
  337. ("kio" ,kio)
  338. ("knewstuff" ,knewstuff)
  339. ("knotifications" ,knotifications)
  340. ("knotifyconfig" ,knotifyconfig)
  341. ("konsole" ,konsole)
  342. ("kparts" ,kparts)
  343. ("kwayland" ,kwayland)
  344. ("kwidgetsaddons" ,kwidgetsaddons)
  345. ("kwindowsystem" ,kwindowsystem)
  346. ("qtbase" ,qtbase-5)
  347. ("qtsvg" ,qtsvg)
  348. ("qtx11extras" ,qtx11extras)))
  349. (home-page "https://apps.kde.org/yakuake/")
  350. (synopsis "Quad-style terminal emulator for KDE")
  351. (description "Yakuake is a drop-down terminal emulator based on KDE Konsole
  352. technology. Features include:
  353. @itemize
  354. @item Smoothly rolls down from the top of your screen
  355. @item Tabbed interface
  356. @item Configurable dimensions and animation speed
  357. @item Skinnable
  358. @item Sophisticated D-Bus interface
  359. @end itemize")
  360. (license license:gpl2+)))