123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373 |
- ;;; GNU Guix --- Functional package management for GNU
- ;;; Copyright © 2017, 2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
- ;;; Copyright © 2021 Tobias Geerinckx-Rice <me@tobias.gr>
- ;;; Copyright © 2021 Brendan Tildesley <mail@brendan.scot>
- ;;;
- ;;; This file is part of GNU Guix.
- ;;;
- ;;; GNU Guix is free software; you can redistribute it and/or modify it
- ;;; under the terms of the GNU General Public License as published by
- ;;; the Free Software Foundation; either version 3 of the License, or (at
- ;;; your option) any later version.
- ;;;
- ;;; GNU Guix is distributed in the hope that it will be useful, but
- ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
- ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
- ;;; GNU General Public License for more details.
- ;;;
- ;;; You should have received a copy of the GNU General Public License
- ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
- (define-module (gnu packages kde-systemtools)
- #:use-module (guix build-system qt)
- #:use-module (guix download)
- #:use-module ((guix licenses) #:prefix license:)
- #:use-module (guix packages)
- #:use-module (guix utils)
- #:use-module (gnu packages)
- #:use-module (gnu packages compression)
- #:use-module (gnu packages kde)
- #:use-module (gnu packages kde-frameworks)
- #:use-module (gnu packages linux)
- #:use-module (gnu packages pkg-config)
- #:use-module (gnu packages qt)
- #:use-module (gnu packages ruby)
- #:use-module (gnu packages search)
- #:use-module (gnu packages vnc)
- #:use-module (gnu packages xml)
- #:use-module (gnu packages xorg))
- (define-public dolphin
- (package
- (name "dolphin")
- (version "21.08.1")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://kde/stable/release-service/" version
- "/src/dolphin-" version ".tar.xz"))
- (sha256
- (base32 "1vmk9iaylw427x203ccdjhlbah3dr5fz7l3lc113nczq54kcwpbf"))))
- (build-system qt-build-system)
- (native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)
- ("kdoctools" ,kdoctools)
- ("ruby" ,ruby)
- ("ruby-test-unit" ,ruby-test-unit)))
- (inputs
- `(("baloo" ,baloo)
- ("baloo-widgets" ,baloo-widgets)
- ("breeze-icons" ,breeze-icons)
- ("kactivities" ,kactivities)
- ("kbookmarks" ,kbookmarks)
- ("kcmutils" ,kcmutils)
- ("kcompletion" ,kcompletion)
- ("kconfig" ,kconfig)
- ("kcoreaddons" ,kcoreaddons)
- ("kcrash" ,kcrash)
- ("kdbusaddons" ,kdbusaddons)
- ("ki18n" ,ki18n)
- ("kiconthemes" ,kiconthemes)
- ("kinit" ,kinit)
- ("kio" ,kio)
- ("knewstuff" ,knewstuff)
- ("knotifications" ,knotifications)
- ("kparts" ,kparts)
- ("ktextwidgets" ,ktextwidgets)
- ("kwindowsystem" ,kwindowsystem)
- ("phonon" ,phonon)
- ("qtbase" ,qtbase-5)
- ("solid" ,solid)))
- (arguments
- `(#:tests? #f)) ;; TODO: 4/15 tests fail even with offscreen
- (home-page "https://apps.kde.org/dolphin/")
- (synopsis "File manager for KDE")
- (description "Dolphin is a file manager for KDE focusing on usability.
- The main features of Dolphin are:
- @itemize
- @item Navigation bar for URLs, which navigates quickly
- through the file hierarchy.
- @item View properties are remembered for each folder.
- @item Split of views is supported.
- @item Network transparency.
- @item Undo/redo functionality.
- @item Renaming of a variable number of selected items in one step.
- @end itemize")
- (license ;; GPL for programs, FDL for documentation
- (list license:gpl2+ license:fdl1.2+))))
- (define-public dolphin-plugins
- (package
- (name "dolphin-plugins")
- (version "21.08.1")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://kde/stable/release-service/" version
- "/src/dolphin-plugins-" version ".tar.xz"))
- (sha256
- (base32 "0gnmr73ly0djngp3imdi4zm72icj3gilqcshb4ks3rq3lwk408rr"))))
- (build-system qt-build-system)
- (native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)))
- (inputs
- `(("dolphin" ,dolphin)
- ("ki18n" ,ki18n)
- ("kio" ,kio)
- ("ksyntaxhighlighting" ,ksyntaxhighlighting)
- ("ktexteditor" ,ktexteditor)
- ("kxmlgui" ,kxmlgui)
- ("breeze-icons" ,breeze-icons) ;; default icon set
- ("qtbase" ,qtbase-5)))
- (home-page "http://www.kde.org/")
- (synopsis "VCS-Plugins for Dolphin")
- (description "This package contains plugins that offer integration in
- Dolphin with the version control systems: Bzr, Git, Mercurial, Subversion.")
- (license license:gpl2+)))
- (define-public khelpcenter
- (package
- (name "khelpcenter")
- (version "21.08.1")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://kde/stable/release-service/" version
- "/src/khelpcenter-" version ".tar.xz"))
- (sha256
- (base32 "09ayg8kb4b4v30xjm8ca5csw1axipn1336mq2sfqra5qwkj8d93y"))))
- (build-system qt-build-system)
- (native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)
- ("kdoctools" ,kdoctools)))
- (inputs
- `(("grantlee" ,grantlee)
- ("karchive" ,karchive)
- ("kbookmarks" ,kbookmarks)
- ("kcodecs" ,kcodecs)
- ("kconfig" ,kconfig)
- ("kcoreaddons" ,kcoreaddons)
- ("kdbusaddons" ,kdbusaddons)
- ("khtml" ,khtml)
- ("ki18n" ,ki18n)
- ("kinit" ,kinit)
- ("kio" ,kio)
- ("kjs" ,kjs)
- ("kparts" ,kparts)
- ("kservice" ,kservice)
- ("kwindowsystem" ,kwindowsystem)
- ("libxml2" ,libxml2)
- ("breeze-icons" ,breeze-icons) ;; default icon set
- ("qtbase" ,qtbase-5)
- ("xapian" ,xapian)))
- (arguments
- `(#:tests? #f)) ;; 1/1 test fails
- (home-page "https://apps.kde.org/help/")
- (synopsis "KDE documentation viewer")
- (description "KHelpCenter uses meta data files which describe the
- documentation available in the system. Each document is represented by a meta
- data file and shown as an entry in the KHelpCenter navigation tree view. The
- meta data contains information about title and short description of the
- document, the location of the document and some more information like how to
- search the document and translations of title and description. Document
- hierarchy is represented as hierarchy of the meta data files. Directories are
- also described by a meta data file which contains the same information as a
- document meta data file.")
- (license license:gpl2+)))
- (define-public konsole
- (package
- (name "konsole")
- (version "21.08.1")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://kde/stable/release-service/" version
- "/src/konsole-" version ".tar.xz"))
- (sha256
- (base32 "0v74yrblwakbmy0p4x5j9lhmqyavgsffahr51bh5r5qcgx0cafjv"))))
- (build-system qt-build-system)
- (native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)
- ("kdoctools" ,kdoctools)))
- (inputs
- `(("kbookmarks" ,kbookmarks)
- ("kcompletion" ,kcompletion)
- ("kconfig" ,kconfig)
- ("kconfigwidgets" ,kconfigwidgets)
- ("kcoreaddons" ,kcoreaddons)
- ("kcrash" ,kcrash)
- ("kdbusaddons" ,kdbusaddons)
- ("kguiaddons" ,kguiaddons)
- ("ki18n" ,ki18n)
- ("kiconthemes" ,kiconthemes)
- ("kinit" ,kinit)
- ("kio" ,kio)
- ("knewstuff" ,knewstuff)
- ("kglobalaccel" ,kglobalaccel)
- ("knotifications" ,knotifications)
- ("knotifyconfig" ,knotifyconfig)
- ("kparts" ,kparts)
- ("kpty" ,kpty)
- ("kservice" ,kservice)
- ("ktextwidgets" ,ktextwidgets)
- ("kwidgetsaddons" ,kwidgetsaddons)
- ("kwindowsystem" ,kwindowsystem)
- ("kxmlgui" ,kxmlgui)
- ("breeze-icons" ,breeze-icons) ;; default icon set
- ("qtbase" ,qtbase-5)
- ("qtscript" ,qtscript)))
- (arguments
- `(#:tests? #f)) ;; TODO: 2/15 tests fail even with HOME, offscreen, SHELL, debus
- (home-page "http://www.kde.org/")
- (synopsis "Terminal emulator similar for KDE")
- (description "Konsole is a terminal emulator, similar to xterm, built on
- the KDE Platform. It can contain multiple terminal sessions inside one window
- using detachable tabs. Konsole supports customizable schemes, saved sessions,
- output monitoring and more.
- This package is part of the KDE base applications module.")
- (license ;; GPL for programs, LGPL for libraries, FDL for documentation
- (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
- (define-public krfb
- (package
- (name "krfb")
- (version "21.08.1")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://kde/stable/release-service/" version
- "/src/krfb-" version ".tar.xz"))
- (sha256
- (base32 "0l28l9wmfxf6vihxr86pwxj027fkz0k0pwkif8had0s4swc9jfnx"))))
- (build-system qt-build-system)
- (native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)
- ("pkg-config" ,pkg-config)
- ("kdoctools" ,kdoctools)))
- (inputs
- `(("kcompletion" ,kcompletion)
- ("kconfig" ,kconfig)
- ("kcoreaddons" ,kcoreaddons)
- ("kcrash" ,kcrash)
- ("kdbusaddons" ,kdbusaddons)
- ("kdnssd" ,kdnssd)
- ("ki18n" ,ki18n)
- ("knotifications" ,knotifications)
- ("kwallet" ,kwallet)
- ("kwidgetsaddons" ,kwidgetsaddons)
- ("kwindowsystem" ,kwindowsystem)
- ("kxmlgui" ,kxmlgui)
- ("libvnc" ,libvnc)
- ("libxcb" ,libxcb)
- ("libxtst" ,libxtst)
- ("breeze-icons" ,breeze-icons) ;; default icon set
- ("pipewire" ,pipewire)
- ("qtbase" ,qtbase-5)
- ("qtx11extras" ,qtx11extras)
- ("xcb-util-image" ,xcb-util-image)
- ("zlib" ,zlib)))
- (home-page "https://apps.kde.org/krfb/")
- (synopsis "Desktop Sharing utility")
- (description "KDE Desktop Sharing is a server application that allows you
- to share your current session with a user on another machine. The desktop
- session can be viewed or even controlled remotely by any VNC or RFB client,
- such as the KDE Remote Desktop Connection client.
- KDE Desktop Sharing can restrict access to only users who are explicitly
- invited, and will ask for confirmation when a user attempts to connect.
- This package is part of the KDE networking module.")
- (license ;; GPL for programs, LGPL for libraries, FDL for documentation
- (list license:gpl2+ license:lgpl2.0+ license:fdl1.2+))))
- (define-public ksystemlog
- (package
- (name "ksystemlog")
- (version "21.08.1")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "mirror://kde/stable/release-service/" version
- "/src/ksystemlog-" version ".tar.xz"))
- (sha256
- (base32 "1vv0wbb3npbq8r0mq8y5lc36qx1hxdjxygfcnw2h9hm4dwl8mc5v"))))
- (build-system qt-build-system)
- (native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)
- ("kdoctools" ,kdoctools)))
- (inputs
- ;; Not including Journald since this is not used in guix
- `(("karchive" ,karchive)
- ("kcompletion" ,kcompletion)
- ("kconfig" ,kconfig)
- ("kcoreaddons" ,kcoreaddons)
- ("ki18n" ,ki18n)
- ("kiconthemes" ,kiconthemes)
- ("kio" ,kio)
- ("kitemviews" ,kitemviews)
- ("ktextwidgets" ,ktextwidgets)
- ("kwidgetsaddons" ,kwidgetsaddons)
- ("kxmlgui" ,kxmlgui)
- ("breeze-icons" ,breeze-icons) ;; default icon set
- ("qtbase" ,qtbase-5)))
- (home-page "https://apps.kde.org/ksystemlog/")
- (synopsis "System log viewer")
- (description "This program is developed for being used by beginner users,
- which don't know how to find information about their Linux system, and how the
- log files are in their computer. But it is also designed for advanced users,
- who want to quickly see problems occurring on their server.
- This package is part of the KDE administration module.")
- (license license:gpl2+)))
- (define-public yakuake
- (package
- (name "yakuake")
- (version "21.08.1")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://kde/stable/release-service/" version
- "/src/yakuake-" version ".tar.xz"))
- (sha256
- (base32
- "1x41jrkvlff8x5qcd12lcrv6zqzw7jqw02ikpmqv1v4gw7lz94w9"))))
- (build-system qt-build-system)
- (native-inputs
- `(("extra-cmake-modules" ,extra-cmake-modules)))
- (inputs
- `(("breeze-icons" ,breeze-icons)
- ("karchive" ,karchive)
- ("kconfig" ,kconfig)
- ("kcoreaddons" ,kcoreaddons)
- ("kcrash" ,kcrash)
- ("kdbusaddons" ,kdbusaddons)
- ("kglobalaccel" ,kglobalaccel)
- ("ki18n" ,ki18n)
- ("kiconthemes" ,kiconthemes)
- ("kio" ,kio)
- ("knewstuff" ,knewstuff)
- ("knotifications" ,knotifications)
- ("knotifyconfig" ,knotifyconfig)
- ("konsole" ,konsole)
- ("kparts" ,kparts)
- ("kwayland" ,kwayland)
- ("kwidgetsaddons" ,kwidgetsaddons)
- ("kwindowsystem" ,kwindowsystem)
- ("qtbase" ,qtbase-5)
- ("qtsvg" ,qtsvg)
- ("qtx11extras" ,qtx11extras)))
- (home-page "https://apps.kde.org/yakuake/")
- (synopsis "Quad-style terminal emulator for KDE")
- (description "Yakuake is a drop-down terminal emulator based on KDE Konsole
- technology. Features include:
- @itemize
- @item Smoothly rolls down from the top of your screen
- @item Tabbed interface
- @item Configurable dimensions and animation speed
- @item Skinnable
- @item Sophisticated D-Bus interface
- @end itemize")
- (license license:gpl2+)))
|