ncdu.scm 2.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. ;;; GNU Guix --- Functional package management for GNU
  2. ;;; Copyright © 2014 John Darrington <jmd@gnu.org>
  3. ;;; Copyright © 2018–2021 Tobias Geerinckx-Rice <me@tobias.gr>
  4. ;;;
  5. ;;; This file is part of GNU Guix.
  6. ;;;
  7. ;;; GNU Guix is free software; you can redistribute it and/or modify it
  8. ;;; under the terms of the GNU General Public License as published by
  9. ;;; the Free Software Foundation; either version 3 of the License, or (at
  10. ;;; your option) any later version.
  11. ;;;
  12. ;;; GNU Guix is distributed in the hope that it will be useful, but
  13. ;;; WITHOUT ANY WARRANTY; without even the implied warranty of
  14. ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. ;;; GNU General Public License for more details.
  16. ;;;
  17. ;;; You should have received a copy of the GNU General Public License
  18. ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
  19. (define-module (gnu packages ncdu)
  20. #:use-module (gnu packages)
  21. #:use-module (gnu packages ncurses)
  22. #:use-module (guix licenses)
  23. #:use-module (guix packages)
  24. #:use-module (guix download)
  25. #:use-module (guix build-system gnu))
  26. (define-public ncdu
  27. (package
  28. (name "ncdu")
  29. (version "1.16")
  30. (source (origin
  31. (method url-fetch)
  32. (uri (string-append "https://dev.yorhel.nl/download/ncdu-"
  33. version ".tar.gz"))
  34. (sha256
  35. (base32
  36. "1m0gk09jaz114piidiw8fkg0id5l6nhz1cg5nlaf1yl3l595g49b"))))
  37. (build-system gnu-build-system)
  38. (inputs `(("ncurses" ,ncurses)))
  39. (synopsis "Ncurses-based disk usage analyzer")
  40. (description
  41. "Ncdu is a disk usage analyzer with an ncurses interface, aimed to be
  42. run on a remote server where you don't have an entire graphical setup, but have
  43. to do with a simple SSH connection. ncdu aims to be fast, simple and easy to
  44. use, and should be able to run in any minimal POSIX-like environment with
  45. ncurses installed.")
  46. (license (x11-style
  47. (string-append "https://g.blicky.net/ncdu.git/plain/COPYING?id=v"
  48. version)))
  49. (home-page "https://dev.yorhel.nl/ncdu")))